Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Product Custom Forms Not Working on 7.1


Go to solution Solved by paul2009,

Recommended Posts

Site URL: https://www.maggiereadjewellery.co.uk/jewellery/p/horizon-three-stone-ring

Hi, I'm having issues with the product custom forms on my website. When you click add to cart, the custom form pops up and then disappears before you can select any options. Some of my products have ring size options, gemstone choices and metal choices so to set them up as individual variants would be an absolute nightmare. Or is there simpler way around the variants that I'm missing? I'd ideally like all of the choice options on the product page - is there a way around this without have a separate variant attached to each option? Thank you!

Link to comment
  • Solution
1 hour ago, magreaduk27 said:

I'm having issues with the product custom forms on my website. When you click add to cart, the custom form pops up and then disappears before you can select any options.

This is due to custom code snippets that you've added, including at least three versions of jQuery which shouldn't be there and could slow down your site unnecessarily.

I recommend you remove all the code (from Code Injection) and then test again. The problem should disappear. you can then carefully add code one section at a time until you identify which section is causing the problem. I do recommend being very cautious about installing code that you don't understand as it could affect your site's reliability and security.

sf-digital-signature-logo-email145.png.46606a2288a2847f44d81b9b7b58f3a5.png
Hi! I'm Paul, an independent Squarespace Consultant since 2007 and founder of SF Digital, building the features that Squarespace didn't include. Our mini-extensions allow you to pick dates in any format, show prices in other currencies, take orders without payment or improve your cartI value honesty, integrity, transparency and respect . Links in my posts may refer to SF Digital products or may be affiliate links.

Link to comment
53 minutes ago, paul2009 said:

This is due to custom code snippets that you've added, including at least three versions of jQuery which shouldn't be there and could slow down your site unnecessarily.

I recommend you remove all the code (from Code Injection) and then test again. The problem should disappear. you can then carefully add code one section at a time until you identify which section is causing the problem. I do recommend being very cautious about installing code that you don't understand as it could affect your site's reliability and security.

Thanks so much for your help, it's sorted!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...