Jump to content

Can't add hyperlink - is anyone else having this problem?

Recommended Posts

Hi-

I'm on 7.0 Squarespace and recently when I go to add a hyperlink to some text, 80% of the time when I click on the hyperlink icon NOTHING happens and I am seriously going crazy. Wondering if this is happening to anyone else or if there is an idea on how to fix this. I contacted support and they just showed me a video where they could add a link to my site. (not helpful - sometimes I can too!) I have tried Firefox, Chrome, Safari, Chrome in incognito and making sure I had my editor fully expanded. NOTHING has helped.

Also when I click on the text size option (normal h1, h2 etc) the dropdown is transparent making it hard to see - not a major thing but I think these are connected. Neither were a problem until recently when they tweaked the editing interface...

thanks for any thoughts. I really don't want to have to try and migrate to wordpress or elsewhere...

Link to comment

I had an odd editing experience with text links in a text block yesterday. I can't describe exactly what happened other that adding links to text went horribly wrong and I had to end up deleting the text and start over again. It was only three words as I was testing something.

Once I redid the text things worked as expected.

So I can't confirm the issue you are seeing but perhaps we can get other reports of good/bad behaviour? 

Find my contributions useful? Please like, upvote, mark my answer as best , and see my profile. Thanks for your support!

Link to comment

I am having the link editor problem today in both Chrome and Firefox on Mac OS. I thought I fixed it on Chrome by clearing the cache but it has returned after a couple of successful uses. This is with 7.0.

The behavior I see is that clicking on text gives you the text formatting menu, but clicking on the link widget causes the entire menu to disappear and no link editor dialog appears. I can continue to modify the text but without any formatting. 
 

Link to comment

Another problem I'm seeing is that when you're editing a page, clicking on a hyperlink to modify it can actually take you to the linked page and you lose your edits! This seems to happen when there are multiple hyperlinks and you've just inspected one hyperlink (i.e. the link editor box pops up and you close it) and then you click on another to inspect it too. Clicking the second one navigates you away from the page you're editing.

So far I'm just fiddling around on a test page, because at this point I'm afraid to edit any our production pages. I emailed Cust Svc yesterday but have not yet heard back.

(The funny thing is that I stumbled onto this while trying to figure out how to delete an apparently orphaned product page so I could reuse its URL. More on that later...)

Link to comment

Not that I'm happy that other people are having issues BUT I didn't think it was just my site so this helps to confirm it. Seriously going crazy. Hyperlink box comes up about 50% of the time. I just cleared my cache and it worked for 2 seconds and now the heading options aren't even showing up. See screenshot attached where there is no "Normal, Heading 1,2,3" etc shown at all. And if I click the link nothing will happen of course. It doesn't matter if I'm in expanded editing mode or not. Currently on latest Firefox but issues on Chrome and Safari too. I have an older PC I might try but none of my files are on it so not ideal.

Screen Shot 2021-10-08 at 2.30.45 PM.png

Link to comment
6 minutes ago, katya said:

See screenshot attached where there is no "Normal, Heading 1,2,3" etc shown at all.

Oh yeah, forgot to mention that -- my formatting menus are disappearing, too. Not all the time, just seemingly randomly. Like, if I wait a few minutes, they work again. Could this be some kind of extreme latency problem?

And are we the only ones seeing this? Maybe there is just one corrupted server on the SS farm? (Or AWS, or whatever they use.) And yes, I've emailed a followup to the support case I opened, but still haven't heard back.

 I should've spent my pandemic year learning Wordpress instead of molecular gastronomy.

Link to comment

I've been having the exact same problem with links, and other things in the formatting bar aren't working for me — I can't center any text, for example. Also the formatting bar is jumping around the page, covering up the text blocks at times. It appears to be working at the moment, but given what others have said here, I'm not confident it'll stay that way. It's been happening to me for about a week now. 

Link to comment
On 10/11/2021 at 8:45 AM, rwmrwm said:

I've been having the exact same problem with links, and other things in the formatting bar aren't working for me — I can't center any text, for example.

I've found that a crude workaround is to copy and paste the text you want to edit into a rich text editor outside of SS, edit it there, then cut and paste the formatted text back into the text block you were editing in SS.

Link to comment

Update: Squarespace help has told me they can replicate the problem (which means they'll stop telling me it's because of customization on my site or choice of  browser) BUT it could be several months before it's fixed . This, combined with the fact that onsite "search" function was so bad we hid the search function rather than have people get bad results, is forcing my hand to look at Wordpress...

Link to comment

Having the exact same problem in both Chrome and Firefox. Customer service was not able to replicate the problem (obviously because it is a sporadic issue) so I posted a crude screenshot to show them the issue at https://youtu.be/eNqW4Iw5wLQ

The only solution for me is to completely shut the browser down, then reopen it. Eventually the issue comes back though and obviously constantly shutting down a browser and reopening it is not an effective solution.

Link to comment
  • 4 weeks later...
  • 2 weeks later...

Hi, I noticed the similar problem yesterday when I was editing my products in the webshop. In the Additional Info section, the text formatting panel is gone. I have to open Office Word, bold text, add hyperlinks, and then paste it into Additional Info's text element. Links work this way but it's super annoying process, especially if I want to link to some of my other pages.

Text formatting panel shows up on on other pages normally as it should. I have 7.1. version, Brine template.

Link to comment
1 hour ago, koni said:

In the Additional Info section, the text formatting panel is gone.

There were some reports of this last week. I recommend you get in touch with Squarespace Customer Care as they can help you to troubleshoot this. You can reach out to them here.

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment
  • 1 month later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.