Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0

Error "Failed to bind to localhost/127.0.0.1:9000" during starting up local server


AgileSSdev

Question

I already installed the Squarespace-server on my desktop (iMac Pro 2017) with this doc. 
https://developers.squarespace.com/local-development

Squarespace-server  --version 1.8.2

But when running squarespace-server https://yourdomain.squarespace.com or squarespace-server https://yourdomain.squarespace.com --auth, I got some errors like "Failed to bind to localhost/127.0.0.1:9000"

Right now, I fixed this issue with Squarespace Support team's help.

If anyone has some issues on Squarespace, please don't hesitate to ask support team. They are very kind.

3.png

Link to comment

1 answer to this question

Recommended Posts

  • 0

Actually, I think the error has to do with the Port you are using. Based on the logs you've provided, the local development server is unable to start because there's a process already bound to port 9000. To address this, you'll either need to identify and kill this existing process or use a different port. The first option is mostly outside the scope of our support, but the steps looks more or less like the following:
 

lsof -i :9000
kill -9 pid_returned_by_lsof

The second option requires appending the --port flag when starting the local development server. For example:
 

squarespace-server https://cyan-tarantula-6j7n.squarespace.com --auth --port=9001

I just hope this forum to help someone that encounter this problem like me.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...