Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Coverage / Indexing Issues - & Page Indexed without Content


Recommended Posts

Site URL: https://www.britannia.smokd.co.uk/

Hey, hoping someone can help out.

I've been struggling with indexing issues for site: britannia.smokd.co.uk for a couple of months now. 
At first google would not index it at all. Squarespace support tried several times to help, by regenerating sitemap etc, but ultimately with no luck.

Eventually, going via our google ads account, I managed to chat online with someone at google, who, despite it not relaly being within the bounds of the 'allowed' chat reasons, did take all of the details and say he will look at it.

A month or so following this chat, we have now appeared in SERPS, but with pretty poor ranking, and no MetaTitle or Description, despite these both being set, and defined on the page (which I have confirmed viewing source). (shown below)

Also, if I search for most keywords that I know are present on the page, they are, apparently not being seen by google e.g. site:britannia.smokd.co.uk bbq (https://www.google.com/search?q=site%3Abritannia.smokd.co.uk+bbq&sxsrf=ALeKk01cr13Hfkhbss8cB7g-PEE_2XkB7A%3A1627920350081&ei=3hcIYcXBBMKW8gLauYagAQ&oq=site&gs_lcp=Cgdnd3Mtd2l6EAEYADIECCMQJzIECCMQJzIECCMQJzIECAAQQzIHCAAQsQMQQzIECAAQQzIKCC4QxwEQrwEQQzIKCAAQgAQQhwIQFDIECAAQQzIOCC4QgAQQsQMQxwEQowI6CwguEMcBEK8BEJECOgsILhCABBDHARCjAjoLCAAQgAQQsQMQgwE6BAguEEM6EAgAEIAEEIcCELEDEIMBEBQ6CwguEIAEEMcBEK8BOggILhCABBCxA0oECEEYAFD7jwtY35ULYMKfC2gAcAJ4AIAByAOIAc8HkgEHMS4zLjQtMZgBAKABAcABAQ&sclient=gws-wiz)

Throughout, I have been attempting to re-index the page in search console with no success - the indexing request is often rejected and then gives no further information as why - and even says the url isn't available on google - which it obviously is (if only poorly) - screenshot also below.

I am thinking that there must be something preventing google from seeing the content on the page, but really can't work out what - there arent robot.txt files blocking access, and the content is in theory easily seen - certainly to a user. 
It is a single page site, which possibly isn't helping, but we really don't need other pages currently. It's built using a standard 'page' rather than a cover in squarespace, which means I've had to set this as a 'non-linked' page - but squarespace have confirmed this is correct and should not be causing these issues.

Hoping someone may have had similar (and resolved) as when even google don't seem to have sorted, I'm starting to lose faith!

Thanks in advance, Tom

 

image.thumb.png.9394509a91d07e6f0f7b8550c5b1c6b6.png

 

 

image.png.b20a127b73a3abf617fe84672ea9ac65.png

Link to comment
  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Posted Images

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...