Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Losing transparency when adding PNG image w/ transparent background as site background image


Recommended Posts

I have an image saved as a png. The image has a transparent background.

I'd like to upload the image as the background on a section of my site (as an image with a transparent background). 

Whenever I try and add the image to the background, the transparency is lost and the used-to-be-transparent background turns black (the site section colour is blue).

Reducing the overlay opacity doesn't help and increasing it creates a blue wash over the image as well. 

I could add a blue background to the image prior to uploading it except I'm trying to get a film grain effect on the image only, not the whole background. Hence the need for transparency. 

Anyone know how to get around this? 

Thanks

 

Link to comment
  • Replies 8
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 2 months later...
On 7/2/2021 at 2:23 AM, tuanphan said:

Hi. Design > Site Styles > Color >> Adjust here.

If you still can't solve, please share link to your site, we can help easier

I am having the same problem. 

I have a transparent .png image that I want to use as. background. As you can see, the theme editor  has a black overlay and black background but the transparent image has a green background. I've removed that colour from every conceivable setting in that theme and still it persists. 

Changing the theme doesn't change that green background on the transparent image. 

 

I produced a work around image but I would love to know how to solve this issue. 

Screen Shot 2021-09-14 at 1.16.12 PM.png

Link to comment
On 9/15/2021 at 12:17 AM, RYH0429 said:

I am having the same problem. 

I have a transparent .png image that I want to use as. background. As you can see, the theme editor  has a black overlay and black background but the transparent image has a green background. I've removed that colour from every conceivable setting in that theme and still it persists. 

Changing the theme doesn't change that green background on the transparent image. 

 

I produced a work around image but I would love to know how to solve this issue. 

Screen Shot 2021-09-14 at 1.16.12 PM.png

Can you share link to page in screenshot?

Email me if you have need any help (free, of course.). Answer within 24 hours.

How to: Setup password & share url - Insert Custom CSS - Page Header - Upload Custom Font - Upload File - Find Block ID - Contact Customer Care

Link to comment
  • 2 weeks later...
16 hours ago, julishtv said:

Following.
Same issue here. I've tried the custom code and stylesite, color, adjust. None of them worked.

It looks like Squarespace has an issue with pngs.

Can you share link to page where you have problem?

Email me if you have need any help (free, of course.). Answer within 24 hours.

How to: Setup password & share url - Insert Custom CSS - Page Header - Upload Custom Font - Upload File - Find Block ID - Contact Customer Care

Link to comment
  • 3 weeks later...
On 10/20/2021 at 9:44 PM, lpotter said:

I'm having this issue as well (my third day using ss!)

Attached is a screen grab of the page, the area above the mountains is transparent in the png but appears black in the image block.

black.PNG

If transparent image, it will use Theme Background Color. 

Edit Section Background

xyz.png.dcd12f0ab7576e8a7999f47132600ef9.png

 

 

Email me if you have need any help (free, of course.). Answer within 24 hours.

How to: Setup password & share url - Insert Custom CSS - Page Header - Upload Custom Font - Upload File - Find Block ID - Contact Customer Care

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...