Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search


Go to solution Solved by paul2009,

Recommended Posts

  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

  • Solution

It sounds like you have the 'conversation mode' enabled in your email inbox.

As the form submissions have the same title and will come from the same (Squarespace) email address, your email client is treating them all as if they are from the same email thread. If you disable the conversation mode, they'll appear individually.

The instructions to disable this will depend on your email provider and/or email application. If you're using Gmail in a browser, you can view the setting by following these steps:

Click Settings in the top-right corner. 

Click See all settings.

Scroll down to the Email Threading section.

Uncheck the box for Conversation view.

Hi! I'm Paul, an independent Squarespace Consultant since 2007 and founder of SF Digital, building the features that Squarespace didn't include. Our mini-extensions allow you to pick dates in any format, show prices in other currencies, take orders without payment or improve your cartI value honesty, integrity, transparency and respect . Links in my posts may refer to SF Digital products or may be affiliate links.

Link to comment

Thanks Paul! will check!
it was

Conversation View:
(sets whether emails of the same topic are grouped together)
Conversation view on
Conversation view off

In another subject if possible, do you know other users of squarespace  that they build AMAZING websites with this product(or there is a ? I always been curious about it.

Link to comment
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...