Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0

Stripe API UPGRADE - does it break Squarespace?


BVStudio

Question

Recently I was rummaging around my STRIPE account, and I noticed that  STRIPE was offering a API Upgrade ( seen on the 'Developer' page ) for my account.

Apparently I am using Stripe API version 2013-12-03
The NEW version is 2020-08-27 ( at the time of this post ).

QUESTION: Should I commit to the API upgrade? Does it play nice with Squarespace and its commerce integration ?
Maybe, I should just leave well enough alone - after-all, I'm still using the old Squarespace Version 7.0- Marquee family template.

Are others successfully using API version 2020-08-27? 

(Note: STRIPE does indeed offer a API-rollback to the older version, for 30-days. My sales on my Squarespace website, however, are not consistent and may occur well after 30 days - making it too late to rollback.)

Edited by BVStudio
Link to post
  • Answers 2
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

2 answers to this question

Recommended Posts

  • 0

As a follow up to my question,
This is the Answer I received from SQUARESPACE Customer Care ( ten days later, on Feb 24,2021 )  regarding the STRIPE's API Upgrade:

" That Stripe API upgrade wouldn't impact our integration with Stripe, so that wouldn't be directly linked to the way we integrate with Stripe. 
We would only recommend upgrading the Stripe API version if you know what is that for, since even though this does not affect our integration with Stripe, it may affect any custom tool you may have created to access that Stripe's API. "

So, it sounds like it would be OK to accept the Stripe API upgrade. In theory, all NEW Squarespace-Stripe commerce customers,  today,  would be signing up with the most current STRIPE API in effect. 

I will update this post in a few months with my experience ( positive/negative) - just to be complete.
 

 

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...