Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Summary block gallery page lightbox


Recommended Posts

Site URL: https://gallery23.co.uk/robinson

Good morning all,

I may be going crazy but I have a feeling that there has been a very recent change in the code which Squarespace generates when adding a summary block to a blank page. The URL I mention (like several other pages on the site) has a summary block at the bottom which points to a gallery page in 7.0. Clicking on an image in the carousel opens the lightbox view BUT it opens the lightbox in the gallery page, not in the page which contains the summary block.

I finished another website less than a month ago. Clicking on an image in, for example, https://www.framednewmills.co.uk/flat opens a similar lightbox BUT in the page containing ths summary block. If I try to add a new page to this website, it displays the clickthrough behaviour which I don't want (i.e. it opens the gallery page first).

I'd be interested to see whether anyone else has the same issue. I'm almost certain that I haven't done anything stupid, but this can never be ruled out 😉

Thanks in advance. Regards,

Trevor.

Edited by TrevorS
To make title more specific
Link to post
  • TrevorS changed the title to Summary block gallery page lightbox
  • Replies 30
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I'm always learning 😊 Funnily enough, I just got a reply from Squarespace Support telling me that the reason my lightbox code wasn't working was because I'd neglected to turn it on. They sneakily put

I thought I knew this already, but I wasn't 100% sure. Thanks for the confirmation. I started using summary blocks only recently and they definitely add an extra dimension in website architecture and

Thanks iannoli! Glad to know that I wasn't going crazy! I noticed the change in interface to resemble 7.1 - which is fine by me - but I did wonder whether the change in behaviour of lightboxes within

Posted Images

Summary block thumbnails work the same for both blog content and galleries. It opens the  blog post and goes to the gallery page. Now the second is where it can look different. If, depending on the template,  the gallery page does not have lightbox capability, like Avenue then it opens the page, but if it does then the page, not the summary, though it looks like it,  opens the image in lightbox mode if that mode is enabled. The summary does what the page does in other words. There are some other limitations too. Avenue gallery summaries cannot use content from a page that is in an index. That is why it is best that tan summary page content, the page it is pulling from, gallery or blog be in the unlinked section of your site. 

Edited by derricksrandomviews
Link to post

Thanks for the reply. What you say makes a lot of sense and is consistent with what I'm seeing. But the behaviour of the lightbox in summary blocks seems to have changed in the last few days.

The template I used where pages successfully open a lightbox in the summary block is Jones. But, as of the last few days, any new summary block I add in the same website displays the behaviour I don't want, i.e. it opens the gallery page and then the lightbox. Older pages work, while newly added ones don't. That's why I wondered whether there had been a recent change in the code generated by summary blocks.

Link to post

Replying to my own post here 😊

I've narrowed it down to the following: the summary block ("sqs-block summary-v2-block sqs-block-summary-v2") is a json block (data-block-json). Among the string of variables is ""lightbox":false,". That is the culprit. But I see no way of changing it to true (although my workaround is to copy all of the block code for each page and put it in a code block, then change "false" to "true". It would be nice not to have to do that).

As I mentioned, the default lightbox variable in my summary blocks seems to have been "true" in the past, whereas it now appears to be "false".

Or I'm missing an obvious confiuration parameter in the summary-block dialogue boxes.

Edited by TrevorS
Clarity
Link to post

Summary block configuration options have to do with layout, appearance, content,  filtering that content. There is no action choice about what happens when an item is selected other than it goes to that content be it an image or a blog post, or event. I am sure you know that already, this info is  for those who are following this thread who are learnng about how to use summary blocks.  

Link to post

@TrevorS, you are correct. This is new behavior and not how it was previously. (Also note that SqSp has changed the interface when setting up a summary block to look like 7.1, so that's another indication of a change). I've not fully explored where and how this limitation exists, but early indications are it's another in a long line of arbitrary changes with no notification from SqSp.

@derricksrandomviews , you are mistaken. in 7.0 it has historically been absolutely true that you can set up a summary block and select lightbox-on-click for images.  I have sites set up that do just that (i make a lot of art portfolio's for artists). 

On 2/8/2021 at 5:55 AM, derricksrandomviews said:

Summary block configuration options have to do with layout, appearance, content,  filtering that content. There is no action choice about what happens when an item is selected other than it goes to that content be it an image or a blog post, or event. I am sure you know that already, this info is  for those who are following this thread who are learnng about how to use summary blocks.  

 

Link to post

Thanks iannoli! Glad to know that I wasn't going crazy! I noticed the change in interface to resemble 7.1 - which is fine by me - but I did wonder whether the change in behaviour of lightboxes within summary blocks was somehow linked to the alignment of 7.0 with 7.1. It now seems as though the default behaviour of a summary block on clicking an image is to open the lightbox in the target (e.g. gallery) page rather than in the page where the summary block resides. My workaround is currently to copy the code generated by the summary block, paste it into a code block and change the json variable ""lightbox":false," to true.

I only recently started using summary blocks and I don't remember the specific option to select lightbox-on-click for images. But all of my old pages work that way whereas the option no longer seems to be there.

I've raised the issue with Squarespace. Yet to hear back 😊

Link to post

SqSp support page suggests that summary blocks in grid or wall format should by default "automatically" open in lightbox when summary is from a gallery. That is precisely my situation, but it's not working. I just reached out to SqSp for help. I can report back when I hear.

https://support.squarespace.com/hc/en-us/articles/205812708-Setting-images-to-open-in-a-lightbox#toc-gallery-pages--version-7-0-

 

Here: 

Summary Blocks

When a Wall or Grid Summary Block is connected to a Gallery Page, the images automatically open in a lightbox slideshow. The Summary Block lightbox color is always Dark. Captions display on hover.

The lightbox slideshow affects clickthrough URLs:

  • While viewing the page, images with clickthrough URLs open the clickthrough link when clicked, rather than opening the lightbox slideshow.
  • When the lightbox slideshow is open, clickthrough URLs are disabled.
Link to post

Just heard back from SqSp. It's a bug on their end (no surprises there). Here's what they said: 

I can confirm this is related to an issue with Summary Blocks in Squarespace version 7.0 not displaying lightboxes, on our end. We’ve reported this, and this case, to our Engineering team, and they’re currently prioritizing the issue.

Please keep in mind that there are many moving parts we need to address before we roll out a solution. We thoroughly test all fixes before they’re released to ensure they don’t affect other Squarespace components or customers.

As a result, we can’t guarantee how long it will take to fix issues like the one affecting your site. Also, because of the volume of requests we receive, we can’t always follow up personally when the issue is resolved.

That being said, customer bug reports are an important part of how we continue to improve our platform. If you come across any other unusual behavior, please let us know.

Link to post

Iannoli, I should have been more clear. I didn't mean to say that a summary would not open in a lightbox, I was referrring to the fact that you don't have  the option to enable/disable lightbox as part of the summary block setup itself. The setup is the same in 7.0 for blog content or gallery page. 

Link to post
  • 2 weeks later...

I can confirm the change in summary interface also disable the use of lazy summaries plugin, has anyone found a workaround yet?

Greeting, it's BaNgan from BeyondSpace, I am Squarespace dev focus on provide solutions to enhance feature that squarespace.com can't provide.
Feel free to check my current Squarespace Plugins Developement: Enable Pinch/Zoom on lightbox, 360 Degree Photo block, Seperator Block (SVG Shape divider for sections)
If you find my answer fit your need, let's leave a like or upvote so others with the same issue can find their solution. Thank you

Link to post
  • 3 weeks later...

Can anyone advise a solution for removing the date (but not the Title or Thumbnail) from a Summary block (Carousel style), pulling from a Portfolio page? Example below. I am a code-noob, so detailed instructions are appreciated. Thanks, Kim

 

Screen Shot 2021-03-20 at 10.19.39 PM.png

Link to post
21 hours ago, designer said:

Can anyone advise a solution for removing the date (but not the Title or Thumbnail) from a Summary block (Carousel style), pulling from a Portfolio page? Example below. I am a code-noob, so detailed instructions are appreciated. Thanks, Kim

 

Screen Shot 2021-03-20 at 10.19.39 PM.png

we can use custom css to hide the date, could you share your site url to get the unique id of that summary block?

Greeting, it's BaNgan from BeyondSpace, I am Squarespace dev focus on provide solutions to enhance feature that squarespace.com can't provide.
Feel free to check my current Squarespace Plugins Developement: Enable Pinch/Zoom on lightbox, 360 Degree Photo block, Seperator Block (SVG Shape divider for sections)
If you find my answer fit your need, let's leave a like or upvote so others with the same issue can find their solution. Thank you

Link to post
On 3/21/2021 at 5:30 AM, designer said:

Can anyone advise a solution for removing the date (but not the Title or Thumbnail) from a Summary block (Carousel style), pulling from a Portfolio page? Example below. I am a code-noob, so detailed instructions are appreciated. Thanks, Kim

 

Screen Shot 2021-03-20 at 10.19.39 PM.png

Hi. The option should be under the 'Content' tab. Set primary and secondary metadata to 'none'.

Link to post

TrevorS and derricksrandomviews: the primary and secondary metadata was the first thing I tried, however there seems to be some sort of bug in that menu. When I click those fields for options, here is what I get...

Screen Shot 2021-04-01 at 1.22.04 PM.png

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...