Jump to content

Can't transfer ownership to contributor

Recommended Posts

  • 5 months later...
  • 3 weeks later...
  • 4 weeks later...
  • 6 months later...

Has anyone got an answer to this problem as I have tried a number of ways to problem solve this.  Squarespace haven't responded to my ticket. 

I cannot transfer ownership over to a contributor.

I have cleared cache etc and still to no avail.

Edited by Guest
Link to comment
  • 1 month later...
  • 2 weeks later...

I figured it out guys, thank me later 😛 see screenshot below.

There was a bit of tooing and frowing, but I think this is what got it to work.


After you accept the invite in incognito mode, go back to the account you want to change ownership FROM and change the 'Administration' permissions to 'off' for the account you want to transfer squarespace to.. I think from this, the new account you want to take over as ownership, will finally be there to click in the drop down.



Link to comment
  • 5 months later...
  • 1 year later...

Hello. Same issue: contributor is not showing/available in dropdown to make a transfer. 

I have sent a contributor invite to be admin. It was accepted. The invite was accepted.

It says "Administrator" now under their name in the contributor's list.

I have cleared my browser cache and tried opening an incognito window.

However, the contributor is not showing/available in dropdown to make a transfer. 

Any help is appreciated please.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.