Jump to content

SS7.1 YouTube video not starting at correct timestamp

Recommended Posts

Site URL: https://www.zachkononov.com/press-media

Hi all!

I'm trying to embed a YouTube video to my website with a URL that starts the video at a specific timestamp. I pulled the URL from the YouTube video at that specific timestamp (2:06), but when I play the embedded video, it always starts at 1:45. On my boyfriend's laptop, it starts at 0:00 sometimes and 1:45 other times. I have changed the URL to different timestamps as a test, and it still always starts at 1:45 or 0:00. 

The page with the video is here: https://www.zachkononov.com/press-media. The video in question is the second video on the left, at bottom of the page. 

Regular video URL: https://www.youtube.com/watch?v=4-sJCxXyHg4

Timestamp video URL: https://youtu.be/4-sJCxXyHg4?t=126

Link to comment
  • 1 month later...
  • 2 months later...
12 minutes ago, Colodolo said:

Unable to get the YouTube video to ever embed at a specific timestamp. Instead it always starts at the beginning of the video.

It's no longer possible to add video options to a sharing link on Squarespace. If you want to set the starting point you'll need to use the embed code instead:

embed-video-sqs-feb-2021.gif.41b238aedec6be0c25f9ac241379c398.gif

Improve your online store with our extensions.
About: Squarespace Circle Leader since 2017. I value honesty, transparency, appreciation and great design ♥.
Work: Squarespace Developer and founder of SF Digital, building the features Squarespace didn't include™.
Content: Links in my posts may refer to SF Digital products or may be affiliate links.

Buy me a coffee

Link to comment
  • 2 weeks later...
  • 3 months later...

I can't get the embed feature recommended here to work in 7.0. and it's weird that some videos I posted last year with timestamps work, but setting up new posts with videos does not allow the timestamps to work. I noticed that youtube also formats the URLs differently and wonder if that has anything to do with it. I don't understand why Squarespace WOULDN'T allow timestamps? 

Here's one link:

www.youtube.com/watch?v=39nTPTg9r2M&t=265s

and here's how youtube reformats the link when you go to share:

https://youtu.be/39nTPTg9r2M?t=265

and here is the embed code

<iframe width="560" height="315" src="https://www.youtube.com/embed/39nTPTg9r2M?start=265" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

and on this page, the above link is the second video on this page. no timestamp.

https://www.richmondfolkfestival.org/2021-performers/2021/6/24/sean-jones-dizzy-spellz-feat-brinae-ali

and here is the webpage from last year, where the timestamp works

https://www.richmondfolkfestival.org/2020-performers/2020/9/26/the-campbell-brothers

help! I really need timestamps to work!

Link to comment
  • 2 weeks later...

I am having a similar problem.  I got the timestamp to work on a recording on 6th June but now I am trying it again today (4th July) it is not working.  I am using the embed code and adding ?start=355  Why is it not working - this is very frustrating - it keeps starting at the beginning.

 

Link to comment
  • 4 weeks later...
  • 6 months later...
  • 6 months later...
  • 4 weeks later...
  • 2 weeks later...
  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.