Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Recommended Posts

Hi there, 

I could use a bit of insight, I feel like this may have very simple solution that I might be over looking;

So, essentially I am unable to edit at least half of the content on my site. Seems like an unusual problem. Been watching various clips and reading though tutorials for the past few hours thought I could give this a shot. 

For example, I can create gallery images, though I cannot change any of that content to my own. I can insert several various text blocks though I cannot include or edit that information to my own. 

As instructed, when looking into editing content -- simply hover over a text block or image and popup should arise asking if you may like to make various changes. This does not occur, for some reason my site will not recognize this. 

I am the site owner, so it is nothing involved with permissions. 

It is also unusual because I have been able to edit SOME content, primarily anything I have created from scratch. The problem may be involving demo content. I'll look into that a bit. 

Well, please let me know if you have any helpful thoughts on this, 

Thanks! 

Link to post
  • 3 weeks later...
  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

I had a similar problem.  Hover or  would not do anything.  Using a surface pro 3, and bluetooth keyboard. Others had problem with using a second display.  I sselected block to a witched to the regular keyboard,and others dropped their second monitor.  Have to keep the mouse clicked down to insert  a block .  

You should be able to edit demo blocks as any others. Check with squarespace email help. They have been responsive to me.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...