Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Sitemap not loading on custom domain


Recommended Posts

Site URL: https://www.mackeydesigns.com

So naturally with the 7.0 to 7.1 change, I had to rebuilt my website from basically the beginning.

ive never had this issue before, but now it seems as though a few days after the change, my sitemap is not loading on my custom domain.

For reference, I don’t manage my domain through SS, I manage several domains in one location and just update DNS data as needed.

In order to get my domain connected to my new 7.1 site, I needed to disconnect it from my existing 7.0 site and re-authorize it for the 7.1 (took only a few minutes).

ever since the change, the sitemap will not load on the custom domain

link: https://www.mackeydesigns.com/sitemap.xml

but does load on the squarespace domain: https://clavichord-bamboo-348s.squarespace.com/sitemap.xml

ive reached out to live chat support twice now, and they keep telling me wait. In my experience it never takes this long for something to update, especially when the SS domain has the correct data displaying.

any help or insight would be great.

 

 

Link to comment
  • Replies 12
  • Created
  • Last Reply

Top Posters In This Topic

Hello! I'm seeing that your XML file is working now. Are you seeing the same thing on your end?

I have nothing but anecdotal evidence to support this, but I believe that Squarespace's XML files are not generated dynamically. At best they only updates XML files daily. So I suspect that this is why Squarespace was telling you that you just needed to wait. But it's good that you checked this as I discovered there was an issue a few months ago where the XML was not regenerating properly and they opened a ticket and fixed a few things.

Link to comment
  • 4 months later...

Site URL: https://www.singoutgeelong.com.au

(One of my very first sites, still new) So I built the website www.singoutgeelong.com.au for a client. They get back to me 4 months later saying its not on google.  I do some research, the sitemap is empty. I contact squarespace and get it fixed. I connect to google search console and resubmit. I've done everything I think of but they are complaining about the time it is taking and the fact that they "still aren't on google" and they want to take it up with squarespace even though they've done what they can. They are on google, I have checked the site:www.singoutgeelong.com.au. So yes they are indexed but the first webpage I see when I search "sing out geelong" is for an event at result 8, not their homepage. Other sites I have done, I did not need to do this as they are the very first result.

PLEASE ANY HELP IS GREATLY APPRECIATED

Link to comment

site:https://www.singoutgeelong.com.au
it's already indexed.

The problem will be the SEO. If the website was positioned well before the sitemap issue I would give it a couple of weeks to see whether the website rankings stabilise before doing any work.

 

G.

 

We provide digital marketing services for businesses that need exposure/sales from search and social media networks. We also build incredibly fast and well optimised multi-language Square Space websites.
Digital Marketing | Marketing Digitale

Link to comment
  • 8 months later...
  • 2 months later...
  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...