Jump to content

Disable automatic translation by Google Translator on my website

Recommended Posts

Site URL: http://mamondeconservation.com

Hi all, 

I am having an issue with the automatic translation offered by Google translate. I have built a bilingual website with a "Home" page (via the link above) which works as an entry page to the two independent websites, one in English the other in Spanish. 

My issue is that the name of my company, which shows in the Home page, is officially in English. When entering the Home page from a Chrome browser configured in Spanish, it automatically translates the name of the company into Spanish, making no sense at all and it is totally misleading. Also, the two buttons that forward to the two websites in the two languages, are translated wrong. "English" is correctly translated into "Inglés", but "Spanish" is translated into "English" (????). 

1885371266_Screenshot2020-09-05at14_55_28.thumb.png.5171f8c2c3dab684d3276c0af1f0155a.png     1429856013_Screenshot2020-09-05at14_55_48.thumb.png.232b3735058178a3f90f6ff7de2d2557.png

Is there a way to disable this automatic translation at least for the HOME page?


many thanks in advance!!!!

Edited by Alejandra
Link to comment
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.