Jump to content

Home Page page setting has "enable" button greyed out. Is this normal?

Recommended Posts

  • 2 weeks later...
  • 3 months later...

@DaleC

I'm unable to reproduce the issue on my test site but here is what I would try to fix the issue.

Create a new page in NOT LINKED area.

Set it as the Home page.

Go to your former home page and see if you can enable it.

Set the former home page back to the home page.

Let us know how it goes.

Find my contributions useful? Please like, upvote, mark my answer as best , and see my profile. Thanks for your support!

Link to comment
  • 10 months later...

I just encountered this issue and chatted with Squarespace help. The solution ended up being this:

  1. Set a different page as your home page
  2. Go back to the disabled page and enable it (the toggle shouldn't be greyed out anymore, now that the page isn't set as your homepage)
  3. Reset that page as your home page.
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.