Jump to content

Import csv error in mailing list

Recommended Posts

Hi There
 

I can not import a csv file of email addresses – always get the same error message: "The first column of your CSV must contain at least one email address."

Of course first column contains nothing but an email address. Also the doc has exactly three columns as requested.  Nothing works.

Even if I download a list that has been created within squarespace, open, export from numbers as csv and import it again – I get the same message. Also tried to export on an pc and exel > same result.

I'm desperate.

Has anyone experienced issues like these and has an idea how to solve?

 

 

Bildschirmfoto 2020-08-31 um 16.46.16.png

Link to comment
  • 3 weeks later...
  • 2 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 1 month later...
  • 1 year later...

I can confirm that MikkoS ' solution works! (thank you!) open the .csv in Google Sheets, resave as a .csv and try uploading again. The error message should dissappear. Squarespace should work on this issue though; I was uploading a .csv file directly downloaded from Squarespace 7.0 site and re-uploading into 7.1 without any interference and it gave me the error message. Very confusing for users!  

Link to comment
  • 1 month later...
On 10/5/2022 at 3:05 PM, Hannah_Sutton_Design said:

I can confirm that MikkoS ' solution works! (thank you!) open the .csv in Google Sheets, resave as a .csv and try uploading again. The error message should dissappear. Squarespace should work on this issue though; I was uploading a .csv file directly downloaded from Squarespace 7.0 site and re-uploading into 7.1 without any interference and it gave me the error message. Very confusing for users!  

At 17/11/2022, I'm using 7.0 version. Perhaps this has been remedied in 7.1 later version. Can someone, please, confirm if this is corrected there? In the meantime, I'll seek to get my Company's version updated anyway.

Link to comment
  • 2 weeks later...

I can confirm an alternative solution.  Open a brand new spreadsheet and save it blank and ensure that the delimiter is a comma or quotation.  Save.  Then copy and paste into it and then save. Then import.  I use openoffice and it worked a treat.  Thanks for this thread though as it helped. Thanks.

Link to comment
  • 7 months later...

This problem occurs in Europe, where excel uses ";" to separate data and not "," as in the US. Theodors comment above helped me to detect the problem. The easiest way out is in Mac or Windows to go to the "system settings" or "Systemeinstellungen", choose "Language&Region" and change it to "English". You can change it generally or just choose specific apps. I chose excel in the apps and it reseted immediately and when I saved my excel file as csv, I could finally import it to Squarespace...😇.

Link to comment
  • 8 months later...
  • 1 month later...
On 3/19/2024 at 10:33 AM, Ohiniya said:

Hi everybody!

Concerning importing csv:s I found, working on a Mac, that it only works if you working in an incognito window.
In both Safari and Chrome. Hope it works for you.

Can confirm that this did not work.

On mac, chrome, incognito.

Edited by luppnow
Spelling
Link to comment
On 7/14/2023 at 11:00 AM, jala said:

This problem occurs in Europe, where excel uses ";" to separate data and not "," as in the US. Theodors comment above helped me to detect the problem. The easiest way out is in Mac or Windows to go to the "system settings" or "Systemeinstellungen", choose "Language&Region" and change it to "English". You can change it generally or just choose specific apps. I chose excel in the apps and it reseted immediately and when I saved my excel file as csv, I could finally import it to Squarespace...😇.

This didn't work for me

Link to comment
On 11/17/2020 at 6:11 PM, MikkoS said:

...and I finally have a solution that works. It seems that the problem persists, if you use Apple Numbers and export them to CSV. The easiest way to go around this is not to use Numbers. Instead I used Google Sheets and it worked beautifully.

This worked! Thank you so much!

Link to comment
  • 1 month later...
On 11/17/2020 at 11:11 AM, MikkoS said:

...and I finally have a solution that works. It seems that the problem persists, if you use Apple Numbers and export them to CSV. The easiest way to go around this is not to use Numbers. Instead I used Google Sheets and it worked beautifully.

This works, and it was the only thing that did. Thank you SO MUCH for saving me hours of adding my contacts one by one importing from Squarespace TO Squarespace. This host gets less and less appealing by the hour. 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.