Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0

Question

I'm working on a 7.0 Brine website & I added this CSS to remove all hypens:

p, h1, h2, h3 {
  webkit-hyphens: none !important;
  moz-hyphens: none !important;
  ms-hyphens: none !important;
  hyphens: none !important;
  }

The hyphens are gone when I preview the site in Squarespace, but on mobile in Chrome & Safari, the hypens are still rendering and I'm not sure why, I've tried everything even setting a max-screen width of 640px to remove them, but they still show up. Any help would be appreciated!

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 0
p,
h1,
h2,
h3 {
  -webkit-hyphens: none !important;
  -moz-hyphens: none !important;
  -ms-hyphens: none !important;
  hyphens: none !important;
}

 


Free Squarespace 7.1 Anchor Link and Accordion Plugins available here!

If I replied to one of your questions with code, it was either CSS or jQuery.

To add CSS, go to Design -> Custom CSS

jQuery needs some additional steps. Head here: https://code.jquery.com/ and click on minified, under jQuery 3.x and copy that code into Squarespace.

After you put that code into the code injection section in Squarespace, you can add the code I supplied. The code from me will need <script> added before it and </script> added after it (only for jQuery).

There are two places that you can add the code, one is site wide (adds to all pages). Settings -> Advanced -> Code Injection

The other is for a specific page (adds to one page only). Pages -> Gear Icon next to the page -> Advanced

Share this post


Link to post
  • 0
3 hours ago, rwp said:

p,
h1,
h2,
h3 {
  -webkit-hyphens: none !important;
  -moz-hyphens: none !important;
  -ms-hyphens: none !important;
  hyphens: none !important;
}

 

This worked, thank you!!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...