Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Can no longer edit text and images in 7.1 with dual monitors


Recommended Posts

Site URL: https://www.anojewelry.com/

Hey there forum peeps,

I'm running a surface Pro with an external LG monitor. Recently being able to edit text and images has stopped working for version 7.1. (https://www.anojewelry.com/) This happens for both chrome and edge browsers. When I unplug the second monitor and to use as just the surface alone, the text and image-editing functions work fine.

Editing with dual monitors in a 7.0 site works just fine. (Heartbasedleading.com)

Anybody else experiencing this problem? 
 

Link to post
  • Replies 8
  • Created
  • Last Reply

Top Posters In This Topic

I have the same issue - it relates to the latest version 7.1.  Brought it upon their chat service but basically they seem to admit there is an issue but are not doing anything about it    Pity as having to change providers

Link to post
  • 3 weeks later...

I couldn't figure out WHAT my problem was and was getting very frustrated. Just added a second monitor yesterday and then suddenly couldn't edit my client's site. Thank you so much for sharing this. What a ridiculous issue. I really hope they fix it soon as so many of us depend on dual monitors for our work. 

Link to post
  • 2 weeks later...

I use a surface pro 3, testing squarespace ver 7.1,  can edit text if I use a tab to get to a simple text box, but otherwise , it is almost impossible to get the mouse to trigger a block for editing.  No external monitor.  Anyone find a solution?

Link to post

I changed my keyboard back from a bluetooth to microsoft's keyboard / cover . Now working.  Hover with mouse now opens blocks for editing.  Some sort of conflict with external devices?  

Link to post
  • 4 weeks later...
  • 3 weeks later...

Same issue here. I have tried the following (without success):

  • Updated Windows10
  • Installed latest drivers for my Surface Pro
  • Installed latest drivers for connected peripherals
  • Attempted in Chrome, Firefox, and Edge - all updated to latest version. Edge *almost* works but still functionally useless.
  • Disabled other mouse devices in Device Manager
  • Problem is not present with USB mouse plugged in while not docked.
Edited by MrMikeGriffith
Link to post
Guest
This topic is now closed to further replies.

×
×
  • Create New...