Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
kellyherrick

facebook pixel doesn't work

Recommended Posts

Site URL: https://www.kellyherrick.com/

I'm not  tech person and i'm having boundless trouble getting my facebook pixel to work on my squarespace site. Squarespace help desk suggested I try here.

I added a pixel code injection as per the instructions. but then had to delete it... not sure if I've deleted all the code, and now it won't let me add a new pixel code. I was wondering if I should delete line 13 in the attached image? It looks similar to the other code I deleted (don't judge me, lols!). I have also attached a pic of the error code I get

I have added the facebook pixel chrome extension after reading another help topic and it says my site has a pixel but has not been activated yet. I have no idea what I'm doing. Would appreciate any help!

It may be that I haven't got it right in squarespace or in facebook, I really don't know... but it will def be user error 🤦‍♀️

Thank you for reading and helping

Kelly

IMG_20200603_110843.jpg

IMG_20200603_110548.jpg

Share this post


Link to post

Hi Kelly,

Also experienced similar issues myself, there is no easy way of working with facebook or squarespace on these issues!

 

I found this on the squarespace site, which may help with removing and adding facebook pixel:

https://support.squarespace.com/hc/en-us/articles/115015760107

"I don't have pixel code in Code Injection, but I still see an error message when I add my pixel ID

If you're seeing a red error message in the Facebook Pixel panel, but your Code Injection panel looks correct, you may have Facebook Pixel code in Google Tag Manager.

To fix this, remove the pixel code from Google Tag Manager and publish the changes in Google. After you save those changes, return to your Squarespace site and add your pixel ID." 

I set up google tag and added the code they give you, onto my Header CSS and it seemed to allow me to add the facebook pixel back onto my website?!

I have no idea though, so could be completely giving you silly advice, but it worked for me. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...