Jump to content

Is it possible to disable Google Address Autopopulate feature in checkout

Recommended Posts

Site URL: http://www.littleloaves.je

Hi everyone, 

I'm having a bit of trouble where customers on my site are finding it difficult to input their addresses due to the Google Autopopulate function at the checkout. I live in Jersey in the Channel Islands which is not indexed properly on google maps, leaving a lot of properties off the map. As such, when a customer is typing in their address having typed in their house name or number, when they see their street pop up they click it, but it deletes everything they had already inputted, which most of the time goes unnoticed. This is meaning I am having to contact a lot of customers to get their correct address. 

Is there a way of disabling this feature?

Thanks 🙂 


Link to comment

Hi , It's Easy , Simply copy the code below and paste in Settings>Advance>Code Injection and paste it in Header:

    $( document ).on( 'focus', ':input', function(){
        $( this ).attr( 'autocomplete', 'off' );

Please Have a look and let me know if it works 🙂

Link to comment
17 minutes ago, hdocker said:

Thanks for this, I really appreciate it! I've added it in, but it still seems to be showing up. See the attached image for what I mean. 

Screenshot 2020-05-11 at 14.59.27.png

Oh I though you was talking about the auto filling of Cart form , Unfortunatley  This can't be done in any way possible as Squaresapce manages this functionality , But as work around you can add a anoucment  banner on top  in which you can direct customer to avoid using the auto adderss seletcor etc 🙂

Link to comment
  • 8 months later...
  • 2 weeks later...

I am having the same issue. We're based in Lancashire in the UK, and we deliver nationally. Every day I need to correct a number of addresses manually using Royal Mail's address checker, as well as contacting customers for their house number. There absolutely needs to be a way to disable this 'feature'. I've placed test orders and even my own address postcode 'suggestion' is incorrect. It's not obvious that you can override the suggested address with your own, so the enter experience is frustrating for our users.

Link to comment
  • 3 months later...

We are having the same issue. When the customer selects their street address from the dropdown Google menu, the whole address info disappears and it doesnt allow them to enter the address again. Please fix this issue! This has created a very awful customer experience for our clients!

Best wishes,
Zara from Shiraz and Daryan

Link to comment
  • 11 months later...


As I understand it the auto complete is done at the browser level so SS has nothing to do with it.

As a previous post in this thread demonstrates code can be used in some circumstances to turn off the browser autocomplete feature, but not on the checkout page, it is a SS security feature.

You could request of SS customer service that they provide an option to disable auto complete on the checkout page but I don't have much hope of that actually happening. However if you don't vote your voice can't be heard.

Find my contributions useful? Please like, upvote, mark my answer as the best ( solution ), and see my profile. Thanks for your support! I am a Squarespace ( and other technological things ) consultant open for new projects.

Link to comment
  • 10 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.