Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Banner Video quality is very low, how to improve it?


Recommended Posts

Hello,

I am working on a website where I need to add a video from Youtube as a Banner.

Everything works fine but the quality of the video in the banner is really low and all pixelated. I'd like those to be at least at 720, better at 1080.

How can I fix this? 

This is the video I am embedding: 

I've tried with this URL: https://www.youtube.com/watch?v=BIIJXp-gumY

and with this: https://youtu.be/BIIJXp-gumY

Thank you!

Link to comment
  • 2 weeks later...
  • 2 weeks later...
  • 5 weeks later...
  • 7 months later...

Squarespace formatting tips don't address this issue. They are recommending optimizing for speed, not quality. We are a visualization firm and having this same issue. Video quality is paramount. Perhaps someone has figured this out. Super frustrating and would likely be a reason we would dumb Squarespace if it can't be fixed. Our videos look beautiful on YouTube and awful in our website.

Link to comment
  • 4 weeks later...
  • 1 month later...
  • 4 weeks later...

Are you embedding video directly from You tube or just uploading it by yourself ? But If you are uploading a video at your own directly into the site, it will slow down the speed for your site. And I think video is not a good option, you can add images like infographics it will also engage the user and will not impact badly too much on your site's speed. What is your site all about ? Is it about Read light novels or any service related site ?

Link to comment
  • 3 weeks later...
  • 2 weeks later...

I'm having the same issue (YouTube link to video). From what I can make out it is to do with the pushed quality of the video. For some reason it defaults to 480p. If I go to the video on YouTube and change the settings in the player to 1080p and return to my site, it's fine. There has to be a way to force externally linked videos to only play at the best settings. 

Link to comment
  • 1 month later...

@PixelForge code works for Vimeo videos. Ive just done some scouring and it seems if you add
" ?vq=hd1080 " to the end of the embed code, it'll default to 1080p videos for Youtube.

Its worked for my site! 

On 5/26/2021 at 9:15 PM, PixelForge said:

I'm having the same issue (YouTube link to video). From what I can make out it is to do with the pushed quality of the video. For some reason it defaults to 480p. If I go to the video on YouTube and change the settings in the player to 1080p and return to my site, it's fine. There has to be a way to force externally linked videos to only play at the best settings. 

 

On 5/14/2021 at 5:44 AM, BriGuy said:

Looking for help on this as well! Anyone?!?!?

 

 

On 4/24/2021 at 6:08 AM, ckatzzzz said:

I'm experiencing this on Vimeo embedded videos. Anyone have a solution? Are there any Squarespace admins that can offer help?

 

Link to comment

Thank you PixelForge and tommiatke for your suggestions - unfortunately my Squarespace site with a homepage looping background video (on Vimeo) still starts out fuzzy every time.

This could be a deal-breaker for my client.

Squarespace tech folks, please chip in on a solution!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...