Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
j9lemmon

Hide from Search Engines not working

Recommended Posts

Site URL: http://readyanimator.com

When a user Googles the name of my product, readyanimator, Google returns pages that I've hidden in Squarespace, by via Settings > SEO > Hide from search engines. In each case, the pages being displayed by Google are Product Blocks. See screenshot.

What should I do to prevent Google from displaying these pages?

Thanks.

 

GoogleHits-readyanimator-Errors-Screenshot (57).jpg

Share this post


Link to post

Google "should" follow your guidelines on whether to index a page or not, but sometimes they have other ideas. Or if they index a page and then you change the setting to noindex, it can take awhile for that page to drop off their radar. However, if you have a Google Search Console account you can request that they remove a page from their index and usually they will honor that request.

A few years ago Google indexed my Squarespace built-in domain and I went through a process to remove that from their index and it worked well. I did a write-up here on how to set-up your Google Search Console account and then remove the URLs you don't want in their index.

https://modsquare.io/blog/remove-squarespace-domain-google-search-results

Just scroll about 1/3rd of the way down the page and you'll see a subhead called " Resolution: Use A Google Search Console Account to Remove These URLs" and follow the instructions. Just use your primary domain and not the SQSP built-in domain. 

This is probably going to be the fastest way to get rid of those. It might take up to a few weeks but I'll bet that this clears it up for you.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...