Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0

Script Disabled


Bwoody1026

Question

Hi, I am trying to  add an "Appfolio vacancy listing widget" into my new Squarespace page that is currently being built. I copy and pasted the HTML provided by Appfolio into a "code" block. And it says "Script Disabled." If I try pasting it into just a normal content block, nothing happens. 

Any ideas???

Here is the javascript code:

<script type='text/javascript' charset='utf-8'>
  document.write(unescape("%3Cscript src='" + (('https:' == document.location.protocol) ? 'https:' : 'http:') + "//prp.appfolio.com/javascripts/listing.js' type='text/javascript'%3E%3C/script%3E"));
</script>

<script type='text/javascript' charset='utf-8'>
  Appfolio.Listing({
    hostUrl: 'prp.appfolio.com',
    //propertyGroup: 'My Group Name',
    themeColor: '#676767',
    height: '500px',
    width: '100%',
    defaultOrder: 'date_posted'
  });
</script>
 

 

Link to post
  • Answers 6
  • Created
  • Last Reply

Top Posters For This Question

Top Posters For This Question

Popular Posts

Ok, here are some photos to show what happened. I AM NOT A TECHIE. So I had to play around with the advice and see what happened.     

Posted Images

6 answers to this question

Recommended Posts

  • 1

It is normal behavior.

To avoid scripts that cause problems while you are in edit mode, the script will be disabled. After inserting, open the web page to see the results. Do not check in edit mode.

You can send your question to my email to get faster answer. / How to Setup Password & Share URL 

-- I'm Tuan, work for a non-profit project (build free libraries). I check the forum once or twice a day to help out the community. If you don't see me answering your question, you can send it to the email above. 

Link to post
  • 1

In Code Block where you inserted, DO NOT check Display Source

You can send your question to my email to get faster answer. / How to Setup Password & Share URL 

-- I'm Tuan, work for a non-profit project (build free libraries). I check the forum once or twice a day to help out the community. If you don't see me answering your question, you can send it to the email above. 

Link to post
  • 0
10 hours ago, tuanphan said:

In Code Block where you inserted, DO NOT check Display Source

Hi, I'm having the same exact issue.  tuanphan - I tried to uncheck Display Source, but you're not able to if javascript is selected as the type in the dropdown.  If I change the type to HTML, I can uncheck Display Source, though.... Any ideas?

Screen Shot 2020-04-04 at 11.25.36 AM.png

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...