Jump to content

Import: "Missing column Add PRODUCT ID column" When the column is there

Recommended Posts

Right. This is ridiculous but it has just worked for me:


1. Don't use the Squarespace CSV template. It's not correct as far as I can see. Some of the instructions disagree with other instructions; such as entering categories .
2. Use Google Sheets - NOT Numbers and NOT Open Office (I can't say anything about Excel as I don't have it.)
3. Make a single product in Squarespace that matches what you want to bulk upload and which works.
4. DOWNLOAD that product from Inventory in Squarespace.
5. Bring it into Google Sheets.
6. Import your bulk product into Google sheets, placing it below the existing correct data.
7. Match everything up in the columns made by the working product
8. Remove example product from Google Sheets
9. Download the Google Sheets spreadsheet as a CSV
10. Import into Squarespace.
 

  • You can leave the Product ID and Variant ID columns (the first two) blank as per SQSP instructions.
  • The file that you downloaded (Step 4.) can be named anything. I uploaded all my products with a file called: "SquareSpace All Products - products_Feb-11_06-02-11PM.csv"
  • When I uploaded this file back into SqSp, I confirmed in the dialogue box that I wanted to replace the existing file and it worked perfectly. By the way, by this time every product had automatically been given a Product ID and Variant ID. I added a new product that didn't have either IDs and it still worked.
  • This all means that you can keep the products file up on Google and just add to it as you create products. You can bulk add tags or whatever info you need, just make sure you keep the format exactly the same.
Edited by McSherry
additional info.
Link to comment
  • 3 weeks later...

Almost March 2022 and this glitch still exists 😕

I work with Excel. After going through all the solutions suggested in this thread, I confirm that using the Google Sheets workaround is the only way that worked for me.

Disappointing as I upgraded my plan to get that bulk .csv upload feature mostly...

Link to comment
  • 1 month later...

Thank you!

This completely fixed my upload errors. I wish this was included in the instructions or the instruction video.

I used Excel and it worked just fine. Just had to make sure it is saved as a Comma Separated Values (.csv) format instead of the CSF UTF-8 Comma Delimited (.csv) format. Correct one highlighted below. 

2088609057_ScreenShot2022-03-31at5_27_44PM.png.f5d87fcf4564cc09eba6d6fd48b3100b.png

Link to comment
  • 2 weeks later...
  • 2 months later...

I was just having this issue and this thread helped me solve it. Anyone currently searching for help with this and is using NUMBERS on a mac, don't save your document and try to upload it. go to File > Export to > CSV...

simply saving it changes it to a .numbers file which is why you'll get the error. Hope this helps!

Link to comment
  • 4 months later...

I know this is an old post, but I had a solution that ended up working for me.

The headers that are being used for the exports/samples are wrong. I had Product-URL as a header in my export and when I imported back into SquareSpace unedited, it couldn't find the missing column Product URL. I ended up removing the dash and it was able to import successfully. So verify that the missing header is matching. Hopefully this helps others!

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.