Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Import: "Missing column Add PRODUCT ID column" When the column is there


Recommended Posts

So I got the importing worked out and I want to add a ton more products to a store.

I exported a CSV, added another product as a test, and imported the new CSV and got the following error:

"Missing column
Add PRODUCT ID column"

So I go to check the CSV and it's right there as the first column. I'm baffled by this one. How can I solve this? I have a ton more to add to my store.

Link to comment

I just tried using Google Sheets (I was previously using Numbers on my mac) .  I made the changes in google sheets, then exported it as a csv file.  I then imported this csv to my website and I did not get the error message any more and all the changes I made were there.  Hope this helps.  

Link to comment
  • 2 months later...
  • 4 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 2 weeks later...

Hey @alexamargs

From what you are describing it seems the issue might be related with the the .csv file formatting. Most likely that's the reason why double-checking the .csv file was the suggestion. If you keep experiencing issues with importing your products even after you have ensured that the file meets the required formatting rules, continuing the conversation with Customer Support would be the best approach to get further assistance. 

Link to comment
  • 2 weeks later...

Hey @raeroshow -- I have also struggled for hours and just realized the walkthrough video suggested users to use google sheet. So I did the same -- download the template -> upload it to google drive -> convert it to google sheet format -> copy paste all the data to the google sheet -> and then export the csv file.  And it works. Yay!

Edited by cantocookingclub
Link to comment
  • 4 weeks later...

Hi, all!

After a redundant and circuitous dialogue with the support team—one that I imagine many of you have similarly had—I was directed to reference the "Completing the product import .csv file" article, ensuring that all allegedly required columns were filled on my sheet. 'Product URL' and 'Categories' are, for example, among the so-called required elements despite the site's ability to auto-generate URLs for cells left blank and to hold shop items without category tags. The "Missing column, Add PRODUCT ID column" error message clearly takes issue with that particular leading column, making it especially confusing when the support reps directed me to the Product URL column and others after it—but ultimately the whole thing is a glitch.

After creating upload sheets in both Numbers and Excel, saving in multiple formats and adjusting in minute ways, I found that a .csv upload will work successfully if the file name remains unchanged from the original template filename given by Squarespace, "product_import-v2.csv". This solution worked for me three times in total after innumerable instances of the "Missing column, Add PRODUCT ID column" message, and though I certainly can't explain how it circumvents the glitch that lives in the system's upload process, I hope it well help some of you!

Link to comment
  • 3 weeks later...

I have tried the solutions mentioned above, and nothing has worked. I can't get a hold of technical support over the weekend so no way to correct this. As of last check, all of my columns were filled in correctly, and the only thing holding me back is no 'Product ID column', which is the first column in the document. I was hoping keeping the filename 'product_import-v2.csv' would help my like the guy above me but still didn't work. Anyone know of any other tips? I transferred it all to Google Sheets and am exporting from there. 


Link to comment
  • 1 month later...

I hate to say it, but the easiest solution is to go through Google Sheets. I have years of experience in excel and CSV and just could not get it to work so copied to Google Sheets.

Really disappointed in SquareSpace with this, it should be easy. They would be much better of stating clearly "use google sheets" and save yourself time and effort.   


Edited by Rupert
Link to comment
  • 3 weeks later...

YES OMG THIS IS SO ANNOYING. So Squarespace tells us we can make bulk edits by downloading their csv file and then when we make no changes to the headings they tell us the format of the headings is wrong. Cmon guys. If we are paying for the more expensive plan with this being touted as a benefit, you need to fix this. I tried all solutions listed above and the only one that worked was the google one. 

Link to comment
  • 2 weeks later...
On 10/19/2020 at 12:52 PM, jaredknppr said:

a .csv upload will work successfully if the file name remains unchanged from the original template filename given by Squarespace, "product_import-v2.csv". 

Thanks for posting this! I've been baffled by this error. I use Numbers and was about to try Google (err) ... Tried this first and it saved time and further aggravation. Thanks again. 🤗

Edited by Bea000
Link to comment

I've been having this issue too and has been so frustrating.  HOWEVER i managed to get it working (no thanks to the lazy answers to make sure you are using the templates and complying with the "Completing the product import .csv file" support page)

With Excel, there are multiple CSV Save-As options.  If you use the "CSV UTF-8 (comma delimited)" option, it wasn't working.  So instead, i used the simpler "CSV (comma delimited)" option and it worked first time.   Would like to see this documented somewhere on the Squarespace support.

Edited by PeterWard
issue update
Link to comment
  • 6 months later...

I have been struggling with this topics for months and never had someone at squarespace's support who was able to find a solution UNTIL Conor helped me out 3 days ago.

The issue for me was :

I work on a Mac with numbers while there was no issue opening and saving the CSV file the issue was the format in which CSV file was made by numbers. Resulting in having the document saved/converted with commas instead of 

Months of stress and manual updated to hundreds of products and no one at squarespace was able to identify the issue !!

However, it is now working perfectly, thanks Conor !

The solution for me was :
1. export the file from squarespace "inventory"
2. "import" the file into Google docs sheets
3. make all changes without removing anything 
4. save on your disk
5. "import" the file back to squarespace inventory

ps: I am not changing the name originally exported from the inventory while back to the inventory page

Hope this helps others.

Edited by TandS
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

  • Create New...