Jump to content

Small sidebar script works on every page but one

Recommended Posts

Site URL: http://www.importantnotimportant.com

Hi everyone — dealing with what seems like a small but very annoying issue with a code block in my sidebar. It’s a third-party email signup box and it’s on the sidebar on every page of my site.

Unfortunately, the code shows up/works in every page except one, and I cannot for the life of me figure out why. It’s the same exact code, in the same exact place, on every page. 

(I already tried to turn off Ajax but that doesn’t look like an option for my template.)

Any help would be hugely appreciated. Thank you.

Quinn
ImportantNotImportant.com

Newsletter page.png

Podcast page.png

Link to comment
  • Replies 11
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

2 hours ago, Importantnotimportant said:

Site URL: http://www.importantnotimportant.com

Hi everyone — dealing with what seems like a small but very annoying issue with a code block in my sidebar. It’s a third-party email signup box and it’s on the sidebar on every page of my site.

Unfortunately, the code shows up/works in every page except one, and I cannot for the life of me figure out why. It’s the same exact code, in the same exact place, on every page. 

(I already tried to turn off Ajax but that doesn’t look like an option for my template.)

Any help would be hugely appreciated. Thank you.

Quinn
ImportantNotImportant.com

Newsletter page.png

Podcast page.png

Will you please try to paste the news letter code in header and let me know if it works or not .

Link to comment

No, the sidebar exists on every page. I added it once, and it exists everywhere -- it's just that the code isn't loading on that specific page. It works everywhere else. It's a blog page, but I use a blog page for our podcast, too (as seen in the screenshot), and that one loads fine, too. I just don't understand why it's not working on this specific page.

Link to comment
1 minute ago, Importantnotimportant said:

No, the sidebar exists on every page. I added it once, and it exists everywhere -- it's just that the code isn't loading on that specific page. It works everywhere else. It's a blog page, but I use a blog page for our podcast, too (as seen in the screenshot), and that one loads fine, too. I just don't understand why it's not working on this specific page.

Okay can you show me where did you added the code ? 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.