Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0

Cannot insert map URL into code block


cooke

Question

Site URL: https://crane-cow-k3a2.squarespace.com/config/pages

Hi, I am making a Squarespace website for a neighborhood park. It will consist mainly of a map. The test map (hosted by MapTiler, https://api.maptiler.com/tiles/dd6645fb-fe0a-427e-878a-e796b8ac9dec/?key=vVaGF01dkm9skQ34hS2Q#17/29.741/-95.382) displays in a web browser, but when I pasted the URL into a text box in Squarespace as a "code block," nothing appears. I'd be grateful for any suggestion!

Link to comment

13 answers to this question

Recommended Posts

  • 0
14 hours ago, cooke said:

Site URL: https://crane-cow-k3a2.squarespace.com/config/pages

Hi, I am making a Squarespace website for a neighborhood park. It will consist mainly of a map. The test map (hosted by MapTiler, https://api.maptiler.com/tiles/dd6645fb-fe0a-427e-878a-e796b8ac9dec/?key=vVaGF01dkm9skQ34hS2Q#17/29.741/-95.382) displays in a web browser, but when I pasted the URL into a text box in Squarespace as a "code block," nothing appears. I'd be grateful for any suggestion!

Hi @cooke It won't work like this, Either you have to embed the link or make iframe for it , I just made iframe for you, Try adding the  foloowing code  in code block . it will work  🙂

<html>
<iframe src="https://api.maptiler.com/tiles/dd6645fb-fe0a-427e-878a-e796b8ac9dec/?key=vVaGF01dkm9skQ34hS2Q#17/29.741/-95.382" style="height:568px;width:100%;">
 
</iframe>
</html>

 

Edited by humxahafeex
Link to comment
  • 0

Thanks again! However the new code also just appears as text.

Could I be missing a basic step for all Code Blocks? What I am doing is clicking on the middle of the page and pasting the code into a text box. Nothing happens. I also clicked a blue "Publish" button and "Done" in the upper left corner.

Annotation 2020-03-18 094129.png

Link to comment
  • 0
5 minutes ago, cooke said:

Thanks again! However the new code also just appears as text.

Could I be missing a basic step for all Code Blocks? What I am doing is clicking on the middle of the page and pasting the code into a text box. Nothing happens. I also clicked a blue "Publish" button and "Done" in the upper left corner.

Annotation 2020-03-18 094129.png

Oh Got it , I think you are checking display source in code block please do disable/Uncheck that let me attach screenshot. 

 

Let me know if it works or not 🙂

 

disable.PNG

Link to comment
  • 0
2 minutes ago, cooke said:

OK, great video thanks!! Do you know what the map is missing the background? Here's what it is supposed to look like:

Annotation 2020-03-18 112023.png

Glad it Helps , Please mark question as solved , I think maptiler is rendring the map like this , only focusing on the useable part of map  you selected and not displaying other part.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...