Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search
  • 0
DamonCameron

Video playback in full screen by default

Question

Site URL: https://www.damoncameron.com/

I'm wondering if there is a CSS work around to have each video playback in full screen by default once the play button is tapped? Rather than having to tap the 'full screen' button in the vimeo or youtube player which is clunky and unnecessary in this day and age.

For mobile devices its pretty much essential for clean, impactful viewing.

Many thanks

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 0

You could probably do it with JS. You would have to look into it, get some help etc. Plenty of front-end devs out there to collab with.

I agree, it's a common-sense feature. After all, SQS's main thing is "rich experiences" that are easy to create and manage. Playing multiple videos on load or when playhead is clicked makes sense to me.

For now, in 7.1 I'm using full bg video on our new site (sorry, no link yet). The main problem here is that it's YouTube, Vimeo or bust - take your pick. Whereas Squarespace should allow us to upload our clips natively, skipping the nonsense of 3rd party linking and crap playback/looping, they'd have to host and manage and facilitate that bleepshow. So part of me doesn't blame them!

YT shows it's ugly links and player chrome on load, and on loop. Yet SQS says we should keep video loop lengths short for faster loading. Kind of defeats the purpose of looping if the loop isn't seamless, right? At least for my purposes. The result is a butt-ugly transition, and a totally un-pro vibe.

Haven't tried Vimeo load yet. Hoping it's not the same problem. As in, hoping it loads and loops without any visible "Vimeo" bs. I don't have my hopes up though :/

Share this post


Link to post
  • 0

No answer, just feedback... I saw a work around for this using 7.0 templates, but I've spent hours trying to figure out a way to have the video play either full screen or in a modal in 7.1 without any success. Interesting, it seems that video has taken a back seat in 7.1 (imho).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...