Jump to content

HTML comment not working in Markdown block

Recommended Posts

I use a Markdown Block to create a table showing whena particular class is being held. When the class is filled I switch the time column to  CLOSED by moving HTML comments between two lines for that column. The Markdown code is shown in Image below.  I switch between the actual time and CLOSED by moving the HTML comments (<!--  --> between  the two code lines for the time column. This works fine.

image1.thumb.jpg.13b03b630a5a438e163c96a5c1d7047b.jpg

 

But for a new class I've entered, with a new time table, inserting an HTML comment around one line generates the "data-preserve" message shown in the image below.   As far as I can tell the markup for  the two tables is identical.  Does anyone know what might be going on?

 

image2.thumb.jpg.38828536b2e0b3a5a776584940b21f11.jpg

Thanks

Link to comment
  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I can see you're missing a semicolon ( ) in your HTML code after the span style attributes in both blocks. It should read style="color: black;" in the first block and style="color: red;" in the second block. 

Not sure if this is what is going to fix your problem, I'd have to take a look at your website so if you're still having problems please share a link to your website.

Link to comment
  • 3 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.