Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Comments Box Doesn't Show On Blog Page


Recommended Posts

I've got all the proper settings done for "enable comments" etc, and the comments box shows when my Blog Page is highlighted under the Page Edit menu, however it does not show in any other situation including the published blog page. I've reread the old forum answers but found no solution, only others with the same unresolved issue.

Any suggestions or ideas?

http://www.josephsavant.com/moto-adventure leads to the link for the following page - http://www.josephsavant.com/newfoundland which in turn does not display the Comment Box or option for Email Subscription. I'm using the Flatiron template.

Screen Shot 2019-10-10 at 1.12.18 PM.png

Screen Shot 2019-10-10 at 1.12.59 PM.png

Link to post
  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I ran into this same issue just now. I was told by Squarespace's live chat support that in Chrome and Safari, due to authentication protocols, the setting "Allow anonymous comments" must be turned on

Posted Images

For anyone with the same issue, customer service explained what was happening in the Flatiron template. The blog landing page doesn't show the comments or subscription boxes, despite displaying the complete blog posts. The reader must click on the title of the blog post for it to take him/her to the actual blog post page where the comments and subscription boxes will appear. It doesn't appear that the Flatiron template allows thumbnail links for blog posts, but only displays the complete post on the list landing page, so it isn't intuitive to click on each blog post title since the posts are all displayed in full length. If there is a way to display thumbnails of each post in Flatiron blog, it isn't listed in the tutorials so I'm assuming that is not an option. I'll update anything I find out, but it seems the Flatiron template is limited in it's blog capabilities that way.

Link to post
  • 10 months later...

I ran into this same issue just now. I was told by Squarespace's live chat support that in Chrome and Safari, due to authentication protocols, the setting "Allow anonymous comments" must be turned on in order to get the comment box to appear. Once I turned that on, the comment box appeared on all posts. Hope that helps!

Link to post
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...