Jump to content

Social links icons no longer appearing, has -unauth appended to class

Recommended Posts

On my site, https://visuals.shunluoifong.com, one of my social icons is showing (LinkedIn) but some aren't (Instagram, Twitter, Vimeo). The icons for IG/Twitter/Vimeo have the "-unauth" appended to the class name...but the accounts are correctly connected via Squarespace settings.

One thing to note is that I am in developer mode and am using a customized template. The code in the template (for the header social icons) is below:


{.section website}
{.if socialAccounts}
<div id="socialLinks" class="social-links dsf-masthead-social" style="float: right;">
{.repeated section socialAccounts}<a{.if profileUrl} href="{profileUrl}" target="_blank"{.or} title="{screenname}"{.end} class="social-{serviceName}"></a>{.end}
</div>
{.end}
{.end}

In the docs I see that the Social Panel launched this past March. My icons were previously showing just fine (but hadn't really paid attention since March) so am wondering if the new panel is creating an issue. Incidentally, the Vimeo icon was displaying correctly for me yesterday. But in troubleshooting, I tried removing it from the Social Links panel, and re-adding it. Now it is not displaying correctly.

Do I need to update my code? I haven't been able to find any sample code in the Developer docs. Any suggestions?

Edited by Guest
Initial Revision
Link to comment
  • Replies 3
  • Created
  • Last Reply

Top Posters In This Topic

  • 8 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.