Jump to content

Can't start local server because port already in use

Recommended Posts

I'm working on this site: https://red-org.squarespace.com/ in dev mode but when I run this command:


squarespace-server https://red-org.squarespace.com --auth

I get the following output:

alt text

Apparently, that's saying my local server at that port is currently being used by another process.

My question is: how can I kill that process?

When I run

ps aux |grep 9000

to view all processes at that port, I get:

alt text

As you can see, each time I run

ps aux |grep 9000

, new PIDs are generated indicating (I think) that those are zombie processes. I try to kill the listed processes with

kill -9 <PID>

but it doesn't do anything, which seems to confirm that they are in fact zombie processes.

So how can I track down those parent processes and kill them so that I can run a Squarespace local server again — or is there another fix here? I'm running Mac Mojave 10.14.6.

Thanks.

Link to comment
  • 1 year later...
  • Replies 1
  • Views 708
  • Created
  • Last Reply

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.