Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

YouTube banner video not loading on mobile device and fallback image does not show either


Recommended Posts

I just went live with a website (www.providancepac.com) and I'm having several issues with the YouTube banner videos not loading both on mobile devices and one in Chrome on MacBook Pro.

  1. On IPhone in Safari the Video does not load and fallback image is a solid color.
  2. On Samsung phone in Chrome video will play but I have to click the website logo and then video plays but not always.
  3. On Ipad in Safari & Chrome fallback image shows but no video.
  4. On Macbook Pro in Chrome video does not play until I reload the site by clicking the logo.

Not finding a fix for these issues in the forum topics I have searched so far. Any suggestions are much appreciated.

Edited by hwitherspoon
Link to post
  • 3 months later...
  • Replies 12
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I just went live with a website (www.providancepac.com) and I'm having several issues with the YouTube banner videos not loading both on mobile devices and one in Chrome on MacBook Pro. On IPhone in

I don't see a banner video embedded on the page at www.inheritedstories.org

sf-digital-signature-logo-email145.png.46606a2288a2847f44d81b9b7b58f3a5.png
Hi, I'm Paul, founder of SF Digital, a specialist company helping Squarespace users by building the features that Squarespace didn't include.
Explore our range of Squarespace Extensions, including the Wishlist, and Datepicker Extension or book a Squarespace Expert for 1:1 help. Note that links in my posts may be affiliate links.

Link to post

The video does play for me on mobile browsers but it is very intermittent, only loading around 30% of the time.

sf-digital-signature-logo-email145.png.46606a2288a2847f44d81b9b7b58f3a5.png
Hi, I'm Paul, founder of SF Digital, a specialist company helping Squarespace users by building the features that Squarespace didn't include.
Explore our range of Squarespace Extensions, including the Wishlist, and Datepicker Extension or book a Squarespace Expert for 1:1 help. Note that links in my posts may be affiliate links.

Link to post
  • 1 month later...

@hwitherspoon Did you figure it out? @paul2009 Do you know more about this issue?

I am having the same issue on www.sunfolding.com.
My video banner (link from Vimeo) has only loaded on 1 mobile device out of the 6 I have tried (both various Samsung and iPhone models and different browsers).
My fall back image does not work either (I also tried a GIF as fall back, but that did not work). It just displays the background color, no matter what I do.

Talked to SS support and they said that because I have custom code on my site, that it might be causing the problem. I have an interactive image embedded in a code block + most header text is code blocks, and I am not looking to remove all that. Is there no way around this or a way to troubleshoot?

Any help appreciated. 

Link to post
  • 4 weeks later...

I have solution but I can chip in and tell you that I have similar problems. Video works on desktop and every Iphone I've tried, but not on Ipads on the same network. Some Android users also get the fallback image instead of the video. 

Will at some point try a different video that is only 720p (not what I'd prefer) and also see if I can just upload a shorter cut of the video and see what happens.

Link to post

I'm experiencing the exact same issue at the moment, it's been on and off for the last 2-3 months, with no real indication as to what's causing it - it's been very random for me.

My only fix is to use a CSS Pseudo element paired with a media query in order to ensure the fallback image appears on mobile. Far from ideal, but it works for the time being.

Edited by ANI.agency
Elaboration
Link to post
  • 4 months later...
Posted (edited)

Confirming exact same issue as of 03JUL20. 

https://www.baunovus.com/

I can live w/o a video on mobile. but expect the "mobile fallback image" to display, which it does not, nor does it display the section color. Confirmed on multiple platforms. Wondering if it might be have anything to do with the convoluted YT server connection? I expect I could try some custom code but was expecting the features to work as documented, which they never have.

Is the best hack based on the CSS pseudo element mentioned by @ANI.agency

EDIT: Just noted Custom CSS is not allowed for the Cover Page, 

Feel free to enlighten me if it is something I didn't understand correctly, but if not, is it recommended to contact support?

Edited by BauNovus
update
Link to post
  • 1 month later...

Has anyone solved this yet?  I am having the same problem.

Can someone explain and paste some CSS for this "CSS Pseudo element paired with a media query" mentioned above?  Sorry I am just trying to build my first website and not very technologically savy....

Link to post
  • 2 months later...

I'm also seeing this. Banner video hosted on youtube not loading on mobile chrome on android.

Remote debugging so that I can inspect the error shows that there is an uncaught exception:

Uncaught (in promise) DOMException: The play() request was interrupted by a call to pause().

 complete with link to explanation of that exception: https://goo.gl/LdLk22

Any ideas how to fix this?

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment


×
×
  • Create New...