Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Search the Community

Showing results for tags 'iframe'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum
    • News and Announcements
    • Getting Started With Squarespace
    • Coding and Customization
    • Commerce
    • Selling & Scheduling Your Services
    • Feedback on Your Site
    • Images and Videos
    • Pages and Content
    • SEO and Marketing
    • Site Design and Styles
    • Resources
  • Colorado Designers's Topics
  • Squarespace Forum Club Guidelines's Topics
  • Austin, TX Designers's Club Discussion
  • New York City Designers's Club Discussion
  • Berlin Designers's Club Discussion
  • SEO Experts's Club Discussion
  • Photographers's Club Discussion
  • Graphic Designers's Topics
  • London Designers's Topics
  • Podcasters's Club Discussion
  • Custom Coding Help's Club Discussion
  • Atlanta, GA Designers's Topics
  • Seattle, WA Designers's Topics
  • San Diego, CA Designers's Topics
  • Dallas, TX Designers's Topics
  • Australia Designers's Club Discussion
  • Minnesota Designers's Topics
  • Minnesota Designers's Topics
  • Copywriters's Topics
  • France Designers 🇫🇷's Topics
  • France Designers 🇫🇷's Topics
  • Portland, OR Designers's Topics
  • Canadian Website Designers's Club Discussion
  • Los Angeles Designers & Devs's Club Discussion
  • South African Designers's Club Discussion
  • Brazil Designers's Club Discussion
  • Developers's Club Discussion
  • German Circle Members's Topics

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Website


Location


Badges


Expert ID

  1. Site URL: https://www.tpc-rodgersleask.co.uk/thesteadings Hi all, There appears to be an update to an embedded Iframe I have been using from a company called Moovit. The problem that has occurred is that now, each time you go onto a page it will snap to the embedded Iframe in order to display an accept cookies message, rather than start at the header of the page (where I would prefer visitors to begin). Does anybody have any suggestions of how to disable this snap to the frame or (less preferably) stop the cookie message coming up? Hope you can help Paul
  2. Site URL: https://www.dylanwhite.me/ Are there any official plans for supporting NFT integration on squarespace ? There is a workaround on one of the forums with iframes / opensea but I couldn’t seem to get it to work with IPFS. As many visual artists increasingly look to sell NFTs either via marketplaces and / or free storefront hub services such as lynkfire, linktree etc I am increasingly wondering why I pay for 2 squarespace sites. Please let me know if you’ve any NFT integration plans soon or I will probably just transfer my url to a linktree that points to hen, fnd, objkt et al. thanks again Dylan
  3. Site URL: https://www.johncervantes.co.uk/music/past I've embedded a Bandcamp music player using an html code block. It looks good on desktop and mobile, but with a screen size in between (iPad etc) the text on the right starts to cover the iframe. I tried to fix it by adding this custom css div#block-yui_3_17_2_1_1655199650584_9623 { min-width: 350px; } But that's not worked. Am I close? Does anyone know what I need to change. Thanks
  4. Site URL: https://www.scottsretreatflorida.com/availability Hi there! I am trying to add the below iFrame code for my availability calendar for my property, to my site. When I try to do this, it loads as a blank box. 6 months or so ago, I was using a different availability calendar iframe and had the exact same issue! I was told to edit the code, but I cannot remember what I had edited! Does anyone have any ideas? iframe code: <iframe src="http://corevacations.ciirus.com/EmbedCalendar.aspx?PropertyID=369739" scrolling="auto" width="800" height="500" frameborder="3></iframe>
  5. Site URL: https://www.SierraLakesRealEstateBrokerage.com Going to mess around with it a while longer. Just hoping one of you guy on this form have encountered this before when inserting a html code. This is how it looks like right now on my page. Cuts of more than 90% of the information.
  6. Site URL: https://rose-gecko-jhss.squarespace.com/driving-directions?noredirect Hi on our website I have a programmed an interactive directions page that I implemented into squarespace as an iframe <iframe width="100%" height="900px" frameborder="0" allowfullscreen src="https://mwmap.piespace.de/"> When I initially put the iframe in, everything is fine but when I reload the page, the menu disappears. Here the site with just with the iframe https://rose-gecko-jhss.squarespace.com/new-page-1?noredirect When I look at the page source, the code for the menu seems to be completely missing. As an awkward workaround, for now I added the code for the menu from a working side into the code section in the pages advanced options. This works but also results in styling issues (mobile view) (seems to be triggered by a script). https://rose-gecko-jhss.squarespace.com/driving-directions?noredirect From comparing to page sources with and without the iframe, it seems like two scripts don't get loaded (see https://rose-gecko-jhss.squarespace.com/new-page-1?noredirect vs https://rose-gecko-jhss.squarespace.com/new-page2?noredirect) Does anyone have an idea, how to fix the issue and get the native menu back?
  7. Site URL: https://www.bodyarch.com/home-fitness-equipment Hi, I have a fitness store page with a bunch of iframe amazon links on it. All of the links appear for me and other people I asked. However, one client doesn't see any of the amazon links when visiting my fitness store page. He has a new iPhone, but one or two iOS updates behind. The amazon iframe links did't appear on his dell laptop either (image attached) Does anyone know why this might be happening? The links appear and work on all other devices and not his? I would like to trouble shoot this. I would also love to have the iframe links appear in two columns on mobiles, they are so narrow, there is plenty of room to fit two columns. I do not like the Amazon blocks, to me, they are awful looking. Thanks so much !! Louis
  8. So I added an iframe code block to my website and it came in great however, when I go to add something to the cart to checkout it says it has added it but the cart is empty.. Any thoughts? My goal is to provide a way for people to checkout using a different point of sales system than what is provided as square has a built in loyalty program.
  9. Hello! I have created a Code Block on a page of my website so I can insert a survey (from the website forms.app). The code provided by the forms website is: <iframe id="" allowtransparency="true" allowfullscreen="true" allow="geolocation; microphone; camera" src="https://my.forms.app/form/61a320417d2e520c5456fd3b" frameborder="0" style="width: 1px; min-width:100%; height:500px; border:none;"></iframe> At the end of it, users should be redirected to a Thank You page (also on my site) but it doesn't work, even though the form does say the user will be redirected. The page doesn't change and the survey goes back to its 1st page. I imagine it's because the Redirect-upon-Completion is in the form's settings (i.e. in a block inside the page) rather than in the page settings itself? Or maybe it's something else entirely. Any help appreciated! (Note: I'm a smart guy but also a complete beginner at coding so I can only make use of detailed instructions when coding is involved.) Thanks!
  10. Site URL: https://almamodern.com/test-lesson Hi, I'd like to embed an iframe that contains a mini course on my site with built in quizzes. I can get the mini course to show; however, once the first visitor completes the quiz, the iframe will not refresh--every new visitor sees the questions already complete. I've tried multiple devices and private browsing, but nothing works. Neither Squarespace or the software developer can help. I appreciate your time! Site password test123 iframe code supplied by developer (I also tried online iframe generators and they don't work either) <iframe src="https://app.7taps.com/wJPdf8lytw" title="7taps course" width="100%" height="680px" style="border-radius: 20px; border: 0; display: block; margin: 0 auto;"></iframe>
  11. Site URL: https://skithefifty.com This iframe code <iframe src="https://www.bivy.com/adventures/us/utah/cold-fusion-couloir-5286725048860672?framed=true" style="width:100%;height:500px”/> in both embed and code blocks causes the site navigation bar to not appear on the site page ( on desktop and eliminates the nav hamburger on mobile) and causes any other blocks on the page below it not to appear. The block with the code does appear. Page with iframe block problems: https://skithefifty.com/cold-fusion Similar page with no iframe block and no problems: https://skithefifty.com/grand-teton Any suggestions on what the issue is?
  12. Site URL: https://www.zantell.com/test%20(pw%20test) I'm trying to embed an element from Spline 3D to this link (pw test) https://www.zantell.com/test Here are the docs from Spline on embedding https://docs.spline.design/exporting-as-public-urls https://docs.spline.design/exporting-as-web-content Here are my links https://my.spline.design/OwVE4q4CCEILheItHqMzVq9r/ <iframe src='https://my.spline.design/OwVE4q4CCEILheItHqMzVq9r/' frameborder='0' width='100%' height='100%'></iframe> It just comes out very thin and horizontal. Any ideas? Thanks all
  13. Site URL: https://www.bakersfieldrealestatepartner.com/ I am sure this has been answered; however, I cannot seem to find it. I have been trying to link my local MLS to my webpage. I copy and pasted the code from my MLS service into a code box as per instructions, but I cannot get it to display the MLS search only the code I pasted in the box. What am I doing wrong? Regards, Marty
  14. Site URL: https://s3dentalsussex.co.uk/onlinebooking Hi , I need a little bit of help. Since the implementation of the strong customer authenication in March 2022, my online booking page is not functioning properly. Previously the site i built for a dental practice has an online booking page which allowed their patients to book appointments online and take payment via stripe. They do not have access to edit the online booking page itself but i was able to embed the page with an iframe to fit into the their website so that the online booking was contained within their actual site. www.s3dentalsussex.co.uk/onlinebooking. I had install the code - <p> <iframe src=" https://onlinebookinguk.3pointdata.com/soe/new/S3 Dental?pid=UKTBT01" width="100%" height="1100" style="border:medium solid rgb(0,0,0)"></iframe> </p> This worked fine until the recent SCA which involves the online booking page itself having an internal redirect where the stripe allows for customer to fill in their card details before returning to the website. https://support.stripe.com/questions/strong-customer-authentication-sca-enforcement-date When you currently try and use the online booking you go through the process but when you need to enter the bank details you are left with the blurred out screen which is waiting for the card details to entered on a screen which is presented. If you use the onlinebooking link directly in a browser then it all works fine. I could just install a button and open up the page directly but this takes the customer out of their website, so trying to integrate it all. Is there anyway to code the online booking page to work like it previously did? Really appreciate all help.
  15. Site URL: https://thekindestgoodbye.com.au/cremation-edenhills Hello. Having an issue with a Jotform product order form cutting off in the iframe when categories are expanded. Need to somehow increase the height of the iframe or make it expand as the form does. Elsewhere people have suggested disabling Ajax loading but my template does not seem to allow this
  16. Hi everyone, I've scoured the forums trying to find a solution to my problem. Here's the sample page I'm working on: https://www.mydryeyedata.org/symptoms-list/how-it-started I'm trying to embed an iframe element on my site (on a blog post, actually). I created a survey and want to have a blog post for summary data of each question, which is accessible by an embeddable link provided by the survey platform, which should go to this page: https://www.questionpro.com/t/ZRhJQhZGgEqYG. <iframe src='https://www.questionpro.com/t/ZRhJQhZGgEqYF' width='100%' height='600' frameBorder='0'></iframe> When I'm editing in Safari or in a private tab, I just see empty boxes. I tried chrome and once I allowed unsafe elements I got the grey frowny face saying "www.questionpro.com refused to connect". I've contacted them about why their embed isn't working, but I haven't ruled out that this is a Squarespace issue. Things I've tried: I know the url is https Putting the above code into a code block doesn't work; frowny face. Putting the url in an embed block says it's not valid. Using specific code in the embed block and adding custom CSS also doesn't work; small box and frowny face. I tried the following per a few help articles (e.g. https://answers.squarespace.com/questions/69710/why-cant-i-interact-with-iframe-content.html) Code in embed block (grey < / >): <div style="text-align: center; -webkit-overflow-scrolling: touch; overflow: auto;"> <iframe src="https://www.questionpro.com/t/ZRhJQhZGgEqYG"></iframe> </div> Custom CSS: (is height: 100% valid? I'm embedding like 100 iframes on my site, and some are a lot taller than 600px. I could also choose some random value) my-iframe iframe { height: 100%; width: 100%; margin: 0; padding: 0; border-style: none; /* to ensure proper scrolling and overflow handling on mobile devices, put this styling in a div wrapper around the iframe because it's unreliable in css: -webkit-overflow-scrolling: touch; overflow: auto; */ } Since chrome says www.questionpro.com refuses to connect, I've contacted them. I'm not sure if they'll be able to solve anything or if this is a square space issue. Btw when I put the embed code provided into something like https://html5-editor.net/ it also doesn't work, leading me to think that it's a QuestionPro problem. @alxfyv @Jay Wilson Jr @raptra @alxfyv Thanks in advance, I'll be sure to provide updates and let everyone know what worked.
  17. Site URL: https://www.instituutnova.be Hi all, I'm trying to embed customer reviews with an iframe in Squarespace 7.0 . I've added the iframe from the software that collects the reviews in a html code block on my Squarespace page, but the reviews don't show. I've checked that source URL is https, so there shouldn't be a security issue? Am I doing something wrong? Thanks a lot for your insights! URL:https://www.instituutnova.be iframe: <iframe src="https://client.optios.net/js/widget/feedback/feedback.html?optios_id=9796" style="width: 100%; height: 800px; background-color: white;"></iframe>
  18. Site URL: https://www.spacescan3d.com/ Hi everyone, I'm not very well equipped to explain this issue. I'll give my explanation and then the email response from Dree at Squarespace. Thank you all in advance: I embedded a virtual tour from my Matterport account on my Squarespace site home page (Linked above). The virtual tour has two "mattertags" inside it (one out the front door and one on the back deck). These tags have deep links that should link the user to a second virtual tour. They work in my Matterport account and in a browser with the share-link, sort of. They worked perfectly when I created them--the backyard link would take you to the back side of the second location and the front walkway link would take you to the front side of the second location. Now all links just take you to the first position of the second location: (https://my.matterport.com/show/?m=kik9SeKPF6f). They don't work on Squarespace at all. Both Matterport and Squarespace directed me to the other company but Squarespace did a little extra digging for me (thank you Dree) and sent me the following email that I hope will explain the situation better: After investigating further I was able to find that the tour you've installed isn't loading the link included within the tour regardless of the Squarespace site that it is loaded on. There are no specific elements or other code that I can locate in your site that would be conflicting with the tour, and it looks like the issue is due to the specific link that is set up in the code for the tour. When I locate the link, it directs here:https://my.matterport.com/show/?m=752mTx7kamx&cloudEdit=1&sr=-2.95%2C.58&ss=1&qs=1 Here's a short video showing where I found that:Locating link within Matterport tour (video) If I view that link on a separate browser that isn't connected to Squarespace, I can see that it doesn't load as well. As we discussed in chat, we can't help troubleshoot code, and since the code used to add the tour is built through iFrame, we'd be unable to see how the specific link is set up. Since Matterport built and manages the tour widget, they will need to help to locate why that specific link isn't working. I've copied that code here for more context: I recognize that this may not be the answer that you were looking for, but I hope this helps to pinpoint the issue a bit further. I've linked to Matterport's support here just in case you need it:https://support.matterport.com/s/contactsupport?language=en_US If Matterport still tries to direct you back to Squarespace, please note that our troubleshooting code is out of Squarespace's scope of support, so I would recommend posting your issue into our Squarespace forum here: forum.squarespace.com The experts in our forum can take a look at your specific issue and they may be able to help to see how it is interacting with Squarespace's code. I'm at a loss here and Matterport is not being helpful, so far, at all. Please, if you can, help me!
  19. Site URL: https://juxtapose.knightlab.com/#preview-embed Hello I would like to implement a before/after slider on my Squarespace portfolio, with the ability to show my work with ‘before and after’ retouching/edited photos. I was building my Squarespace portfolio/website on a trial. I found a ‘before-after slider’ code from this code provider https://juxtapose.knightlab.com/ I made the befor after code uploading the photos to dropbox, and had inserted this code in a codeblock: <iframe frameborder="0" class="juxtapose" width="100%" height="803" src="https://cdn.knightlab.com/libs/juxtapose/latest/embed/index.html?uid=2cfd5df6-aab6-11ec-b5bb-6595d9b17862"></iframe> It worked very well and everything was fine. When I then subscribed to Squarespace with a personal plan, the functionality of the code stopped working. I found out that a personal plan does not support javascript or iframe code. I then tried to embed a different code from juxtapose in an embed block instead: https://cdn.knightlab.com/libs/juxtapose/latest/embed/index.html?uid=2cfd5df6-aab6-11ec-b5bb-6595d9b17862 The before/after slider was working now on my personal plan with the embed block, and everything was fine. I thought I had found a solution. But two days after without me making any changes, now the embed code stopped working. Instead of the before/after slider, now black boxes with a youtube play button icon are showing instead. I am wondering what happened? Why did the code stop working? Can anybody help me if it is possible to make a before/after photo slider functionality on a personal plan? For me, it is very expensive to have to subscribe to a business plan ( almost the double price of a personal plan) just to make this before/after slider work in my portfolio. Thank you in advance!
  20. Site URL: https://www.bi-analytics.work/portfolio Hi, I have created a webpage in squarespace to show my Power BI portfolio. To do so, I use iframes to embed each of the dashboards that I want to display. Unfortunately, they do not load properly all the times. Sometimes they do sometimes they don't. I have been trying to find a solution in the forum and I have tried several things: is 7.1 so no AJAX involved, I disbled the clickjacks option and checked the code (it looks ok). So I am out of ideas. I would really appreciate if anyone could give me a hand. Web: https://www.bi-analytics.work/portfolio And this is how the iframes look like: <iframe title="Market Analysis Mock Portfolio - By Manufacturer" width="1024" height="612" src="https://app.powerbi.com/view?r=eyJrIjoiODhjNjdiMWItZmViMi00NGZjLTkyZTAtMWJhNTkxZDAxM2E0IiwidCI6IjllNzE1ZWNjLTczMDQtNDAwZC1iZDk1LTg2ZTFlZjUyMmE0MSIsImMiOjl9" frameborder="0" allowFullScreen="true"></iframe> When they do not load it looks like this (see attached figure) Many thanks in advance!
  21. We created a short tutorial and a blog post on how to integrate live audio (and video) into your Squarespace project. We are a bunch of audio and conversation enthusiasts in the heart of Switzerland 🇨🇭, dedicated to creating virtual audio experiences that feel like the authentic in-person conversations we all value so much. We believe the right conversation at the right time changes everything. That's what drives us. 😊 Try it out and let me know if we can support you! ✌️
  22. Site URL: https://www.cranewaycraftfair.com/artcraftapplication1 Hi, I have been using a wufoo form on my website, embedded with iframe, and the most common issue reported is the form being cropped and cutting off the lower part and the submit button. I'm guessing this has to do with individual browser settings. In trying to remedy this, I made the iframe dimensions bigger, but in addition to not completely solving the problem, it makes the post submit page clunky with users having to scroll up to see confirmation. There is also an option to embed with javascript, but that does not seem to work. Any ideas?
  23. Site URL: https://redkiteseo.com/ Hello Does anybody know how I can iframe my squarespace website please? I wanted to iframe it on my Google site, but it keeps saying wont connect, i think because of a x frame blocker? Which is bizzare, becuase I can iframe the www.squarespace.com but not my own website. It's a new site so probably 7.1 version at a guess. Any help is much appreciated, thanks.
  24. Site URL: http://www.whereslewisat.com/walking-the-wainwrights/ Hello I am hoping you can help, I contacted one of your Squarespace team members regarding some issues I was having with a MyMaps map on my site, essentially I was wanting to format it so it was wider than 1240px., Tuanphan gave me some code to put in and it did the trick, however, I am wanting to implement the same principle on another map on site, I was wondering if you could help me identify what needs to change in the existing code has given me and then I can swap out the variable to the new one that's needed for the other map? This is the code that has allowed me to put the first map into how I wanted it... ---------------- [data-section-id="61edbd4a0e1ca17f505cc2b1"] .content-wrapper { max-width: 90% !important; padding-left: 0 !important; padding-right: 0 !important; } [data-section-id="61edbd4a0e1ca17f505cc2b1"] .content-wrapper iframe { width: 100% !important; } html, body { overflow-x: hidden; ----------------- This below is the Google Maps MyMaps produces in order to embed on my site through iframe, but it is limited in size, this is for my second map <iframe src="https://www.google.com/maps/d/embed?mid=1z76Ef8zCO849i6amm0Nj3FGijtKACxYu&ehbc=2E312F" width="640" height="480"></iframe> Can you help me identify what needs to change in the first chunk of CCS in order for it to work on my second map? For information my site is www.whereslewisat.com The first map can be found here: https://www.whereslewisat.com/walking-the-wainwrights The second map can be found here: https://www.whereslewisat.com/about-me
  25. Site URL: https://www.smartcompost.nyc/ Hello! I'm using a custom Google Map on my website via the embed data block (iframe). It's sized appropriately for desktop, but when viewed on Mobile, the map extends far beyond the rest of the website, forcing users to pinch and zoom out (per screenshots below). I'm decidedly a novice coder, but is there a simple function I'm missing to have this resized for mobile responsively? I've tried using a script tag outside of the iframe to resize it with no success. Any help would be greatly appreciated, and thanks in advance! xx
×
×
  • Create New...