Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Search the Community

Showing results for tags 'developer mode setup'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum
    • News and Announcements
    • Getting Started With Squarespace
    • Coding and Customization
    • Commerce
    • Feedback on Your Site
    • Images and Videos
    • Pages and Content
    • SEO and Marketing
    • Site Design and Styles
  • Colorado Designers's Topics
  • Squarespace Forum Club Guidelines's Topics
  • Austin, TX Designers's Club Discussion
  • New York City Designers's Club Discussion
  • Berlin Designers's Club Discussion
  • SEO Experts's Club Discussion
  • Photographers's Club Discussion
  • Graphic Designers's Topics
  • London Designers's Topics
  • Podcasters's Club Discussion
  • Custom Coding Help's Club Discussion
  • Atlanta, GA Designers's Topics
  • Seattle, WA Designers's Topics
  • San Diego, CA Designers's Topics
  • Dallas, TX Designers's Topics
  • Australia Designers's Club Discussion
  • Minnesota Designers's Topics
  • Minnesota Designers's Topics
  • Copywriters's Topics
  • France Designers 🇫🇷's Topics
  • France Designers 🇫🇷's Topics
  • Portland, OR Designers's Topics
  • Canadian Website Designers's Club Discussion
  • Los Angeles Designers & Devs's Club Discussion
  • South African Designers's Club Discussion
  • Brazil Designers's Club Discussion
  • Developers's Club Discussion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Website


Location


Badges

Found 6 results

  1. Hi all, I am new to squarespace and trying to setup so I can develop locally. I followed the basic beginner guide and finished it but now I want to develop local instead of push to squarespace with git every change. The issue is whenever I run the command squarespace-server http://mywebsite --auth I get this error below that the ampersand character is not allowed. This is from the powershell script in my npm folder. Every other npm script uses node and for some reason squarespace uses echo. Has anyone else had this issue? Does squarespace not support windows 10?
  2. Site URL: https://iduma-demo.squarespace.com/ Hi, I signed up for business plan but I don't see developer mode.
  3. Hello, I've been trying to get a local SquareSpace server running on a VM (Ubuntu 20.04), following the instructions in https://developers.squarespace.com/get-started When I run npm install -g @squarespace/server I return the following error > @squarespace/server@1.6.2 copyrunscript /usr/lib/node_modules/@squarespace/server > node scripts/copyfile.js build/distributions/local-developer/bin/run.bat darwin:build/distributions/local-developer/bin/osx-local-developer win32:build/distributions/local-developer/bin/win-local-developer.bat linux:build/distributions/local-developer/bin/linux-local-developer build/distributions/local-developer/bin/local-developer copying build/distributions/local-developer/bin/linux-local-developer to build/distributions/local-developer/bin/run.bat npm ERR! code EACCES npm ERR! syscall symlink npm ERR! path ../lib/node_modules/@squarespace/server/build/distributions/local-developer/bin/run.bat npm ERR! dest /usr/bin/squarespace-server npm ERR! errno -13 npm ERR! Error: EACCES: permission denied, symlink '../lib/node_modules/@squarespace/server/build/distributions/local-developer/bin/run.bat' -> '/usr/bin/squarespace-server' npm ERR! [OperationalError: EACCES: permission denied, symlink '../lib/node_modules/@squarespace/server/build/distributions/local-developer/bin/run.bat' -> '/usr/bin/squarespace-server'] { npm ERR! cause: [Error: EACCES: permission denied, symlink '../lib/node_modules/@squarespace/server/build/distributions/local-developer/bin/run.bat' -> '/usr/bin/squarespace-server'] { npm ERR! errno: -13, npm ERR! code: 'EACCES', npm ERR! syscall: 'symlink', npm ERR! path: '../lib/node_modules/@squarespace/server/build/distributions/local-developer/bin/run.bat', npm ERR! dest: '/usr/bin/squarespace-server' npm ERR! }, npm ERR! errno: -13, npm ERR! code: 'EACCES', npm ERR! syscall: 'symlink', npm ERR! path: '../lib/node_modules/@squarespace/server/build/distributions/local-developer/bin/run.bat', npm ERR! dest: '/usr/bin/squarespace-server' npm ERR! } npm ERR! npm ERR! The operation was rejected by your operating system. npm ERR! It is likely you do not have the permissions to access this file as the current user npm ERR! npm ERR! If you believe this might be a permissions issue, please double-check the npm ERR! permissions of the file and its containing directories, or try running npm ERR! the command again as root/Administrator. Can anyone give me any indication as to what must be done to resolve this? I've already tried running the command with sudo before, but it returned a permissions error and all the answers I've searched online indicated that running sudo npm install is something to avoid.
  4. Would like to turn off developer mode for purpose of upgrading Squarespace template to current Squarespace 7.0 or 7.1. Is there an expert who can do live chat or phone with me to help re: steps to do this successfully without losing site data, pages, custom css, code injection, code blocks in pages, etc.?
  5. Hi. I can't connect to squarespace-server. I've got this error: Setting file permissions was not successful. What is supposed to have in .squarespace-local-developer, on my global folder? This file is returning an empty object. And my localhost return a 500 from GET. {"code":500,"message":"There was an error processing your request. It has been logged (ID e1a7cfe94d287020)."} Anyone else? Thanks.
  6. Hi! I'm having trouble installing the @squarespace/server on my new machine (I run into issues with this every time I set it up but am unable to find what I have done to fix it in the past). It claims to install fine (I am using the global flag) however the command continues to return as unfound when I attempt to initialize it.
×
×
  • Create New...