Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Search the Community

Showing results for tags 'developer mode server'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum
    • News and Announcements
    • Getting Started With Squarespace
    • Coding and Customization
    • Commerce
    • Feedback on Your Site
    • Images and Videos
    • Pages and Content
    • SEO and Marketing
    • Site Design and Styles
  • Colorado Designers's Topics
  • Squarespace Forum Club Guidelines's Topics
  • Austin, TX Designers's Club Discussion
  • New York City Designers's Club Discussion
  • Berlin Designers's Club Discussion
  • SEO Experts's Club Discussion
  • Photographers's Club Discussion
  • Graphic Designers's Topics
  • London Designers's Topics
  • Podcasters's Club Discussion
  • Custom Coding Help's Club Discussion
  • Atlanta, GA Designers's Topics
  • Seattle, WA Designers's Topics
  • San Diego, CA Designers's Topics
  • Dallas, TX Designers's Topics
  • Australia Designers's Club Discussion
  • Minnesota Designers's Topics
  • Minnesota Designers's Topics
  • Copywriters's Topics
  • France Designers 🇫🇷's Topics
  • France Designers 🇫🇷's Topics
  • Portland, OR Designers's Topics
  • Canadian Website Designers's Club Discussion
  • Los Angeles Designers & Devs's Club Discussion
  • South African Designers's Club Discussion
  • Brazil Designers's Club Discussion
  • Developers's Club Discussion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Website


Location


Badges


Expert ID

Found 2 results

  1. Hi all, trying to get started with Squarespace developing but can't seem to get the server started. I'm running Windows 10 with node installed globally and available on path (all up to date), and I've also tried installing on Ubuntu via WSL2. On Windows, the error is as shown below: At C:\Users\Iamnotacrook\AppData\Roaming\npm\squarespace-server.ps1:12 char:29 + & "$basedir/echo$exe" off & "$basedir/node_modules/@squarespace/ser ... + ~ The ampersand (&) character is not allowed. The & operator is reserved for future use; wrap an am
  2. Whenever I try to run the server, end up having the issue below. I have already tried to modify the referred file with no success and currently have the version 1.7.0. Any help would be much appreciated. ``` At C:\Program Files\nodejs\squarespace -server.ps1:12 char:29 + & "$basedir/echo$exe" off & "$base dir/node_modules/@squarespace/ser ... + ~ The ampersand (&) character is not allowed. The & operator is reserved for future use; wrap an ampersand in double quotation marks ("&") to pass it a
×
×
  • Create New...