Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

Search the Community

Showing results for tags 'ajax'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Forum
    • News and Announcements
    • Getting Started With Squarespace
    • Coding and Customization
    • Commerce
    • Selling & Scheduling Your Services
    • Feedback on Your Site
    • Images and Videos
    • Pages and Content
    • SEO and Marketing
    • Site Design and Styles
  • Colorado Designers's Topics
  • Squarespace Forum Club Guidelines's Topics
  • Austin, TX Designers's Club Discussion
  • New York City Designers's Club Discussion
  • Berlin Designers's Club Discussion
  • SEO Experts's Club Discussion
  • Photographers's Club Discussion
  • Graphic Designers's Topics
  • London Designers's Topics
  • Podcasters's Club Discussion
  • Custom Coding Help's Club Discussion
  • Atlanta, GA Designers's Topics
  • Seattle, WA Designers's Topics
  • San Diego, CA Designers's Topics
  • Dallas, TX Designers's Topics
  • Australia Designers's Club Discussion
  • Minnesota Designers's Topics
  • Minnesota Designers's Topics
  • Copywriters's Topics
  • France Designers 🇫🇷's Topics
  • France Designers 🇫🇷's Topics
  • Portland, OR Designers's Topics
  • Canadian Website Designers's Club Discussion
  • Los Angeles Designers & Devs's Club Discussion
  • South African Designers's Club Discussion
  • Brazil Designers's Club Discussion
  • Developers's Club Discussion
  • German Circle Members's Topics

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


About Me


Website


Location


Badges


Expert ID

  1. Site URL: https://moreland.edu/form-submission-no-redirect We use Infusionsoft as a form handler and I'm trying to figure out how to submit a form via Ajax to avoid the natural page refresh. As it currently sits, I get a CORS error. I've also tried changing the form data type to 'jsonp' and that did change the error, but did not avoid it. I understand that CORS is controlled by server headers which I can't change on Squarespace but is there another way to get this to work somehow?
  2. I'm creating a GET request from my square space site to Big commerce using ajax API call. But facing 401 unauthorized error. I've attached my code I'm using right now - hope someone can help me out of this problem. const username = "username"; const password = "password"; function make_base_auth(user, password) { var tok = user + ':' + password; var hash = btoa(tok); return "Basic " + hash; } $.ajax({ url: "https://api.bigcommerce.com/stores/{store-hash}/v3/catalog/products", async: true, crossDomain: true, beforeSend: function(xhr) { xhr.setRequestHeader('Authorization', make_base_auth(username, password)); }, headers: { "X-Auth-Client": "secret-key", "X-Auth-Token": "token", "Content-Type": "application/json", "cache-control": "no-cache", }, type: "GET", dataType: "jsonp", success: function(data) { console.log(data) } }); ..
  3. Site URL: https://www.flowfitstudio.com/schedule I have a Vagaro booking widget embedded on my site that won't load. The interesting part is that it loads when I view on mobile and disconnect from wifi, but does not load when viewing on desktop or on mobile when connected to wifi. I've researched this issue and have tried manually disabling Ajax loading by adding the following code to the Header box under Code Injection: <script src="https://content1.getnarrativeapp.com/ss-ajax-loader.js"></script> I tried doing it this way because I do not see the option to disable Ajax loading under Site Styles. This unfortunately did not fix the issue for me. Here is the page: https://www.flowfitstudio.com/schedule Here is the embed data: <div id='frameTitle' class='embedded-widget-title' style='font-size: 23px; color: #333;font-family:Arial, Helvetica, sans-serif; line-height:24px; padding: 18px 10px 8px; text-align: center; -webkit-box-sizing: border-box; -moz-box-sizing: border-box; box-sizing: border-box;'></div> <div class="vagaro" style="width:250px; padding:0; border:0; margin:0 auto; text-align:center;"><style>.vagaro a {font-size:14px; color:#AAA; text-decoration:none;}</style><a href="https://sales.vagaro.com/">Powered by Vagaro</a>&nbsp;<a href="https://sales.vagaro.com/salon-software">Salon Software</a>,&nbsp;<a href="https://sales.vagaro.com/spa-software">Spa Software</a>&nbsp;&amp;&nbsp;<a href="https://sales.vagaro.com/fitness-software">Fitness Software</a><script type="text/javascript" src="https://www.vagaro.com//resources/WidgetEmbeddedLoader/OZqnDJWqD3OcT3qnV3Dy6ZuQlXiz3avV34mC2PeFJ4mC30m9dSycXCu7gevEhAJDXwQ0?v=yMoWiANQbQzJAwksZ6jK1qT2t5vTDseu1XI5dLITxoyW#"></script></div>
  4. Site URL: https://www.thelosttwo.com/blog/four-seasons-beverly-hills Hi All, I am having trouble adding the booking.com affiliate map widget to: https://www.thelosttwo.com/blog/four-seasons-beverly-hills. I copy and paste it but it just shows up as "booking.com" and the map is nowhere to be found. My ajax loading is disabled. This is the code: <ins class="bookingaff" data-aid="2180661" data-target_aid="2180661" data-prod="map" data-width="400" data-height="300" data-lang="ualng" data-dest_id="0" data-dest_type="landmark" data-latitude="34.0730472" data-longitude="-118.3893444" data-landmark_name="300 Doheny Dr" data-mwhsb="0" data-address="Four Seasons Hotel Los Angeles At Beverly Hills, 300 Doheny Dr, Los Angeles, CA 90048, United States"> <!-- Anything inside will go away once widget is loaded. --> <a href="//www.booking.com?aid=2180661">Booking.com</a> </ins> <script type="text/javascript"> (function(d, sc, u) { var s = d.createElement(sc), p = d.getElementsByTagName(sc)[0]; s.type = 'text/javascript'; s.async = true; s.src = u + '?v=' + (+new Date()); p.parentNode.insertBefore(s,p); })(document, 'script', '//aff.bstatic.com/static/affiliate_base/js/flexiproduct.js'); </script> Is there anything I need to change? Thank you!
  5. Site URL: https://brine-demo.squarespace.com/ How would you rewrite this script so it works despite the Ajax loading on the Brine template? Right now it only works if you refresh the page. <script> $(document).ready(function(){ $('.markdown-block .sqs-block-content h3').css('cursor','pointer'); $(".markdown-block .sqs-block-content h3").nextUntil("h3").slideToggle(); $(".markdown-block .sqs-block-content h3").click(function() {$(this).nextUntil("h3").slideToggle();}); }); </script>
  6. Site URL: http://herzbergdesign.com Hi all, I'm working on the website for my design business (not web design, obviously), and am having a small issue. I am using custom images with click-through links, and added a piece of CSS I found online that expands these images when you hover over them (using them on home page as well as a few others). The issue is that they only work after a few page reloads (or very specifically, reloading the "branding" page will make them work throughout the website). After some thorough Googling, I am under the impression that this has to do with AJAX loading. I'd rather not turn this off just to make some dumb CSS animations work. Is there an easy way to make this work? Here's the code: a img.thumb-image { display: inline-block; vertical-align: middle; -webkit-transform: translateZ(0); transform: translateZ(0); box-shadow: 0 0 1px rgba(0, 0, 0, 0); -webkit-backface-visibility: hidden; backface-visibility: hidden; -moz-osx-font-smoothing: grayscale; -webkit-transition-duration: 0.3s; transition-duration: 0.3s; -webkit-transition-property: transform; transition-property: transform; } a img.thumb-image:hover, a img.thumb-image:active { -webkit-transform: scale(1.1); transform: scale(1.1); }
  7. Site URL: https://www.sprowt.uk Hi, I need some help. I am having trouble embedding some code into my site that would allow me to have an embedded flodesk form. It is not appearing, and google suggest that I should disable the ajax. But, I can't seem to find it in the new site design, apparently there is is meant to be a site loading section that I don't have. Can anyone help?? Thank you
  8. I am looking for tips/documentation for connecting to a remote service - in this case, Salesforce - in order to retrieve/render data. My assumptions are that: - I would be building a plugin - I'd need a remote service I can proxy requests through, from my plugin, which would handle the interaction with Salesforce - My requests from Squarespace would be JavaScript-based I don't see documentation for plugin development at https://developers.squarespace.com/. Where can I find resources to guide me? In the case of the last two questions, can I assume that JavaScript is my primary tool, and that Squarespace will not be a substitute for the traditional web server environment I'm accustomed to (apache, php)?
  9. Site URL: https://eduard-slinin.squarespace.com/ I'm building a website in 7.1 and I need to disable Ajax scrolling for a custom plugin I've installed. With the new site styles editor on the righthand side of the page I can't find the section to disable Ajax scrolling anymore. Do you know where I can find this now? website is: https://eduard-slinin.squarespace.com/. password is : working Thanks!
  10. Site URL: https://www.jakeandkylee.com/ I'm using a Honeybook contact form on my contact page, and it doesn't show up when you first click on the contact page. It only shows up when you refresh the page, or go directly to https://www.jakeandkylee.com/contact I have figured out that the problem is Ajax Loading. But when I turn that off, it breaks my site. It makes it so my content overlaps my site logo. Any idea how to fix this?
  11. From what I've read version 7.1 doesn't currently support AJAX Loading (Lazy Loading) for images, instead "it's designed to optimize loading times", but what does that mean? If I have a site with multiple images, would I be better off choosing 7.0 or 7.1, in regards to loading times? Is it possible to add Lazy Loading to images on 7.1 by editing the HTML template and adding some 3rd party JavaScript library?
  12. Site URL: https://about.dataclassroom.com/resource-library I just ran into this problem with some JS embedded on an individual page not running. And when I say not running, I mean not being executed AT ALL when a user navigates to the page. Not just "not working". E.g. console.log("I'm running"); Having searched a bit I found some words on this page https://support.squarespace.com/hc/en-us/articles/115000253288-Ajax-loading that say: Now, that's not quite the same as saying "none of your code will be run" at all 🙂 Anyone know the answer? Maybe update the documentation if it is indeed the case, as my experiments seem to show. All the best, Dan
  13. Site URL: https://www.dexterlakeclubband.com/ On my homepage I have two code blocks that won't load properly. Both display beautifully after I refresh the page. One is an Instagram post that I've used the embed code from IG, the second is a review widget from Wedding Wire. I know the likely issue is Ajax loading being enabled on my Brine Template. However, I don't want to disable ajax-loading for my entire site. Can anyone help me with changes to the html or code so that these elements will be "ajax-enabled" and load properly the first time?
  14. Site URL: https://tunny-purple-2bdn.squarespace.com/ I'm currently putting together a basic site for someone. They want the header links and logo to be up against the same background image (banner image) as the intro. But when the site loads on the screen, the logo and header nav items overlap the top blocks like so: After refreshing the page, it looks fine. Just when you first go onto it. I have already tried turning ajax loading off and tried it with ajax loading on too. Can anyone help with this please :)
  15. My page isn't public yet, which is why I can't provide a URL. When I click on a nav link in the menu, the new page renders twice. This happens very quickly and automatically. I have gone through and found some other people having these issues on different browsers previously. They were related to CSS changes, I haven't made any custom CSS on the site yet. Do you know why the site may be performing in this way? I'm using the a v7.1 theme
  16. Site URL: https://www.pestack.com/vendor-profiles I use a Ajax-based third party application called Knack which I use to power a database platform with many pages. I host this content on my Squarespace page via an embed block. The problem is that Squarespace does not generate the hundreds of pages in this database platform within the sitemap, and Google is therefore not picking up any of these pages. All that the sitemap shows is the URL for the single page where the embed is. This is bad for SEO! Is there some piece of code or approach I can use to get Squarespace to generate the pages within the sitemap? Any help or tips greatly appreciated! Thanks
  17. Squarespace AJAX page loading kills scripts on page. They will not load without a page refresh. Code written to every page initialized with the redirect value will just cause a redirect loop... How do I write a script that doesn't redirect the page initially that is in the header and LISTENS for an AJAX page refresh... and THEN gets reinitialized with a new value to redirect the page? (I've actually asked this question already but my posts aren't getting answered at all, so I'm starting to wonder what the coding and customization board is for if one can't ask a coding and customization question...)
  18. <script> window.Squarespace.onInitialize(Y, function() { location.assign("https://www.squarespace.com"); } ); </script> If I inject this code into the header of a page, shouldn't the browser be directed to squarespace.com...? Nothing happens... Any ideas why? Is my code wrong?
  19. Site URL: https://indigo-chipmunk-42dl.squarespace.com/config/ Hi, I am creating a site and i want to have a folder which when the title of folder is clicked in the navigation bar, it redirects to a page I have tried injecting javascript code for a redirection but it isn't working and I can't seem to make the folder clickable When reading around the subject, I seen people were saying ajax loading needs to be disabled. However for my site i cannot seem to find this option in design. I don't know if its the template I am already using does not support ajax Does anyone have a current way around this?
  20. Hi I have added page code injection to a number of pages on my clients site to change the background colour: <style> section {background-color: #ffffff;!important;} </style> But now the site is live, it only seems to work if you refresh the page. Can I convert that style code to css code? Thanks!
  21. Hi, I am using this tutorial for toggle. https://www.spacetutorials.com/toggle-button-for-content Nothing happens when I switch between buttons i.e. "section 1" shows on page load and on clicking both buttons (section 2 should appear when the right button is clicked). Also I see a bottom scroll (left-right) now. How to fix and make toggle work?
  22. Site URL: https://locqar1.squarespace.com/order I want to post my form data to an external API, but Im unable to override the default submit. I tried using a jquery listener for the submit button but it didn't trigger. Does anyone have any help? IF you need to access the site, the password is 123456
  23. I've added jquery to my site, and I'm trying to override the form submission to post the form to an external api via Ajax but I'm not having any luck. I tried adding a listener to the submit but but it didn't trigger. $('input[type="submit"').on( "click", function() { alert("Button triggered"); }); Can anyone help out? Thanks.
  24. Site URL: https://mommytomom.com/ Hi everyone. I would like to enable Ajax loading on my site but it doesn't work with my social sharing buttons and code I use on a few pages. I am not very knowledgeable with coding so I wanted to ask here if there is anything I can do. Is there a code you can add that makes the page refresh each time? I disabled Ajax for now but can turn it back on to troubleshoot if needed. The social buttons I'm referring to are through Shareaholic, they only show up if you refresh the page. Thanks in advance for any help :) Code injection <!-- BEGIN SHAREAHOLIC CODE --> <link rel="preload" href="https://cdn.shareaholic.net/assets/pub/shareaholic.js" as="script" /> <meta name="shareaholic:site_id" content="73ca7139ab230a40546bce24cbe1c713" /> <script data-cfasync="false" async src="https://cdn.shareaholic.net/assets/pub/shareaholic.js"></script> <!-- END SHAREAHOLIC CODE --> The other code I'm referring to I only have on my secondary navigation pages that I want to look like landing pages. It removes the header and footer. https://mommytomom.com/want-to-work-from-home Pages settings, advanced <style> .Header, .Footer, .Mobile-bar, .Mobile-bar--top, .sqs-announcement-bar-custom-location{ display:none !important; } </style>
  25. Hello! (First Time Here) I'm running into issues with a javascript not loading in a code block for a video player I am trying to implement. The scripts work and load on a local implementation and on a non-squarespace hosted implementation. Here is the code in question: <meta charset="UTF-8"> <html> <head> <script src="https://www.mysite.xyz/vendome/js/jquery-3.1.0.min.js"></script> <script src="https://www.mysite.xyz/vendome/js/jquery.cookie.js"></script> <script src="https://www.mysite.xyz/vendome/webrtc.js"></script> </head> <body> <div class="div-section"> <table> <tr> <td><input type="hidden" id="sdpURL" size="50" value=""/></td></tr> <tr> <td><input type="hidden" id="applicationName" size="25" value=""/></td></tr> <tr> <td><input type="hidden" id="streamName" size="25" value=""/></td></tr> <tr> </table> </div> <div class="div-section"> <video id="remoteVideo" autoplay playsinline controls muted style="width:1000px;"></video> </div> <td><input type="button" id="buttonGo" onclick="start()" value="" /></td> <input type="button" id="buttonCheckStream" onclick="getAvailableStreams()" value="Get Available Streams" /> <script type="text/javascript"> pageReady(); </script> <div> <span id="sdpDataTag"></span> </div> </body> </html> jquery.cookie.js will not load causing the next scripts to not function. When you load the page we get "Uncaught TypeError: $.cookie is not a function". I'm fairly certain that the jquery scripts aren't loading twice and over writing eachother like other posts have suggested. I've tried renaming the the cookie.js as well but no luck. Could this have something to do with AJAX? Is there anything we could do to force the scripts to load? Any advice is appreciated! (Excuse the bad HTML, I'm from a python background.) EDIT: The template is AJAX compatible and the option is enabled.
×
×
  • Create New...