Jump to content

Matt_E

Member
  • Posts

    4
  • Joined

  • Last visited

Everything posted by Matt_E

  1. I don't know where that code is that you're showing. That's not how I have it right now. I was going back between trying different ways to get the CSS to apply so was using a "test" class, but that's not how it is now so not sure where you pulled that code.
  2. So we made the site public, so I think for now it's this hyperlink? https://tarpon-grasshopper-z4nl.squarespace.com/give
  3. Here's the code I was using. Like I said, when I swap out the <a> for a <p> element, remove the href, and change it accordingly in the CSS the styles then apply. In the <> block: <a class=“g_button” href="https://fumcpdx.churchcenter.com/giving?open-in-church-center-modal=true"> Give Online Now </a> In the custom CSS: /* Give Button Styling */ a.g_button { background: #D34B2A; color: #F5F1E9; text-transform: Uppercase; font-family: “Merriweather”, serif; text-align: center; letter-spacing: 1.5px; font-weight: 600; font-size: 1.2em; padding:15px 50px 15px 50px; border: none; border-radius:5px; display: inline-block; } a.g_button:hover { background: #EB693B; }
  4. Hello, My site is not public yet so not sure how to make it visible but this is the problem I'm having. I had several custom buttons made that are pop-ups for our payment processor and contact forms. All the custom styles do not work when applied to an <a> element. I was able to make all the styling apply when I changed the <a> elements to a <p> element and took the href link out, so I know the code works, it just doesn't work with an <a> element and I'm not sure why.
×
×
  • Create New...

Squarespace Webinars

Free online sessions where you’ll learn the basics and refine your Squarespace skills.

Hire a Designer

Stand out online with the help of an experienced designer or developer.