Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Advanced Search

AgileSSdev

Member
  • Posts

    3
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Actually, I think the error has to do with the Port you are using. Based on the logs you've provided, the local development server is unable to start because there's a process already bound to port 9000. To address this, you'll either need to identify and kill this existing process or use a different port. The first option is mostly outside the scope of our support, but the steps looks more or less like the following: lsof -i :9000 kill -9 pid_returned_by_lsof The second option requires appending the --port flag when starting the local development server. For example: squarespace-server https://cyan-tarantula-6j7n.squarespace.com --auth --port=9001 I just hope this forum to help someone that encounter this problem like me.
  2. I already installed the Squarespace-server on my desktop (iMac Pro 2017) with this doc. https://developers.squarespace.com/local-development Squarespace-server --version 1.8.2 But when running squarespace-server https://yourdomain.squarespace.com or squarespace-server https://yourdomain.squarespace.com --auth, I got some errors like "Failed to bind to localhost/127.0.0.1:9000" Right now, I fixed this issue with Squarespace Support team's help. If anyone has some issues on Squarespace, please don't hesitate to ask support team. They are very kind.
  3. Maybe it will be access_type=offline to the end of this following link that you get in a prompt. https://login.squarespace.com/api/1/login Changing access_type=offline to access_type=online, then get a token on your browser, copy it and paste it on cmd terminal window. Definitely, you will enter into local dev mode and open http://localhost:9000 on your browser.
×
×
  • Create New...